aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-10-30 06:54:55 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-10-30 06:54:55 +0000
commit5a08328197d66c63552fa4b85f9e5d7d86d1e1cf (patch)
tree632f8cd954558a2952811964bdcf22b27054dd6a /target/linux
parent6357738509902fbbd6d0b8c8d927c3f3c8ea7d6c (diff)
downloadupstream-5a08328197d66c63552fa4b85f9e5d7d86d1e1cf.tar.gz
upstream-5a08328197d66c63552fa4b85f9e5d7d86d1e1cf.tar.bz2
upstream-5a08328197d66c63552fa4b85f9e5d7d86d1e1cf.zip
ar71xx: don't build uImages for the mikrotik subtarget
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 38598
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/ar71xx/image/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 36181e7a47..f2b6befa8e 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -74,6 +74,7 @@ define PatchKernelGzip
gzip -9 -c $(KDIR_TMP)/vmlinux$(3)-$(1) > $(KDIR_TMP)/vmlinux$(3)-$(1).bin.gz
endef
+ifneq ($(SUBTARGET),mikrotik)
define MkuImage
mkimage -A mips -O linux -T kernel -a 0x80060000 -C $(1) $(2) \
-e 0x80060000 -n 'MIPS OpenWrt Linux-$(LINUX_VERSION)' \
@@ -103,6 +104,7 @@ endef
define MkuImageOKLI
$(call MkuImage,lzma,-M 0x4f4b4c49,$(KDIR)/vmlinux.bin.lzma,$(KDIR_TMP)/vmlinux-$(1).okli)
endef
+endif
define CatFiles
if [ $(2) -eq 0 ]; then \