aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorKoen Vandeputte <koen.vandeputte@ncentric.com>2020-05-08 16:48:19 +0200
committerKoen Vandeputte <koen.vandeputte@ncentric.com>2020-05-08 17:06:10 +0200
commit51a7184a7d06078343bdac5dec69cd5f97de4558 (patch)
tree602a2d6e81709e5a2dd94bf7c134e9ca6beea148 /target/linux
parent5e50515fa6b3e2ddfd7ffb478b2111dc589dfd4e (diff)
downloadupstream-51a7184a7d06078343bdac5dec69cd5f97de4558.tar.gz
upstream-51a7184a7d06078343bdac5dec69cd5f97de4558.tar.bz2
upstream-51a7184a7d06078343bdac5dec69cd5f97de4558.zip
generic: fix patching error on kernel 5.4
Fixes a build error seen when applying the kernel patches. Applying patch generic/435-mtd-add-routerbootpart-parser-config.patch patching file drivers/mtd/parsers/Kconfig Hunk #1 FAILED at 160. 1 out of 1 hunk FAILED -- rejects in file drivers/mtd/parsers/Kconfig patching file drivers/mtd/parsers/Makefile Hunk #1 FAILED at 10. 1 out of 1 hunk FAILED -- rejects in file drivers/mtd/parsers/Makefile This was missed as 5.4 is currently set as testing kernel while the main kernel being used is 4.19 Fixes: 2976e423dc6e ("generic: routerboot partition build bits") Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/generic/pending-5.4/435-mtd-add-routerbootpart-parser-config.patch20
1 files changed, 11 insertions, 9 deletions
diff --git a/target/linux/generic/pending-5.4/435-mtd-add-routerbootpart-parser-config.patch b/target/linux/generic/pending-5.4/435-mtd-add-routerbootpart-parser-config.patch
index 3ab78838b0..4e72aa88a0 100644
--- a/target/linux/generic/pending-5.4/435-mtd-add-routerbootpart-parser-config.patch
+++ b/target/linux/generic/pending-5.4/435-mtd-add-routerbootpart-parser-config.patch
@@ -16,23 +16,25 @@ Signed-off-by: Thibaut VARĂˆNE <hacks@slashdirt.org>
--- a/drivers/mtd/parsers/Kconfig
+++ b/drivers/mtd/parsers/Kconfig
-@@ -160,3 +160,12 @@ config MTD_REDBOOT_PARTS_READONLY
- 'FIS directory' images, enable this option.
+@@ -176,3 +176,12 @@ config MTD_MYLOADER_PARTS
- endif # MTD_REDBOOT_PARTS
+ You will still need the parsing functions to be called by the driver
+ for your particular device. It won't happen automatically.
+
+config MTD_ROUTERBOOT_PARTS
+ tristate "RouterBoot flash partition parser"
+ depends on MTD && OF
+ help
-+ MikroTik RouterBoot is implemented as a multi segment system on the
-+ flash, some of which are fixed and some of which are located at
-+ variable offsets. This parser handles both cases via properly
-+ formatted DTS.
++ MikroTik RouterBoot is implemented as a multi segment system on the
++ flash, some of which are fixed and some of which are located at
++ variable offsets. This parser handles both cases via properly
++ formatted DTS.
--- a/drivers/mtd/parsers/Makefile
+++ b/drivers/mtd/parsers/Makefile
-@@ -10,3 +10,4 @@
+@@ -9,4 +9,5 @@ obj-$(CONFIG_MTD_AFS_PARTS) += afs.o
+ obj-$(CONFIG_MTD_PARSER_TRX) += parser_trx.o
obj-$(CONFIG_MTD_SHARPSL_PARTS) += sharpslpart.o
obj-$(CONFIG_MTD_REDBOOT_PARTS) += redboot.o
- obj-$(CONFIG_MTD_MYLOADER_PARTS) += myloader.o
+-obj-$(CONFIG_MTD_MYLOADER_PARTS) += myloader.o
++obj-$(CONFIG_MTD_MYLOADER_PARTS) += myloader.o
+obj-$(CONFIG_MTD_ROUTERBOOT_PARTS) += routerbootpart.o