aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorHenryk Heisig <hyniu@o2.pl>2016-12-23 18:04:16 +0100
committerJohn Crispin <john@phrozen.org>2016-12-24 06:52:12 +0100
commit4f033b2da67f666a98cce267c2426fb532c90590 (patch)
tree8c02b47ea0afdf4f51ccbe27ac15cb816cf4cb0e /target/linux
parent3a6353d910fc1e9a9fdafbd85c96d96d8d43746a (diff)
downloadupstream-4f033b2da67f666a98cce267c2426fb532c90590.tar.gz
upstream-4f033b2da67f666a98cce267c2426fb532c90590.tar.bz2
upstream-4f033b2da67f666a98cce267c2426fb532c90590.zip
ramips: fix tplink image building fix sysupgrade firmware on MR200
Signed-off-by: Henryk Heisig <hyniu@o2.pl>
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/ramips/image/mt7620.mk9
1 files changed, 5 insertions, 4 deletions
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index d0e89b68a2..24b78cb97b 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -4,7 +4,7 @@
define Build/tplink-header
$(STAGING_DIR_HOST)/bin/mktplinkfw2 -a 0x4 -V "ver. 2.0" -B $(1) \
- -o $@.new -k $@ && mv $@.new $@
+ -o $@.new -k $@ -r $(IMAGE_ROOTFS) && mv $@.new $@
endef
define Build/pad-kernel-ex2700
@@ -45,7 +45,7 @@ define Device/ArcherC20i
DTS := ArcherC20i
KERNEL := $(KERNEL_DTB)
KERNEL_INITRAMFS := $(KERNEL_DTB) | tplink-header ArcherC20i -c
- IMAGE/sysupgrade.bin := append-kernel | tplink-header ArcherC20i -j -r $(KDIR)/root.squashfs | append-metadata
+ IMAGE/sysupgrade.bin := append-kernel | tplink-header ArcherC20i -j | append-metadata
DEVICE_TITLE := TP-Link ArcherC20i
endef
TARGET_DEVICES += ArcherC20i
@@ -54,16 +54,17 @@ define Device/ArcherC50
DTS := ArcherC50
KERNEL := $(KERNEL_DTB)
KERNEL_INITRAMFS := $(KERNEL_DTB) | tplink-header ArcherC50 -c
- IMAGE/sysupgrade.bin := append-kernel | tplink-header ArcherC50 -j -r $(KDIR)/root.squashfs | append-metadata
+ IMAGE/sysupgrade.bin := append-kernel | tplink-header ArcherC50 -j | append-metadata
DEVICE_TITLE := TP-Link ArcherC50
endef
TARGET_DEVICES += ArcherC50
define Device/ArcherMR200
DTS := ArcherMR200
+ SUPPORTED_DEVICES := mr200
KERNEL := $(KERNEL_DTB)
KERNEL_INITRAMFS := $(KERNEL_DTB) | tplink-header ArcherMR200 -c
- IMAGE/sysupgrade.bin := append-kernel | tplink-header ArcherMR200 -j -r $(KDIR)/root.squashfs
+ IMAGE/sysupgrade.bin := append-kernel | tplink-header ArcherMR200 -j | append-metadata
DEVICE_PACKAGES := kmod-usb2 kmod-usb-net kmod-usb-net-rndis kmod-usb-serial kmod-usb-serial-option adb
DEVICE_TITLE := TP-Link ArcherMR200
endef