aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorChristian Lamparter <chunkeey@gmail.com>2023-05-27 20:59:22 +0200
committerChristian Lamparter <chunkeey@gmail.com>2023-05-27 22:05:14 +0200
commit323530090352c6d1cbdef9fedda58a1ac20f7ef2 (patch)
tree3fb32e8f320939fdcf5e75e8006cd691dd801fc4 /target/linux
parentb5a5751706830a90b00ec7df9924a3c67a1d5753 (diff)
downloadupstream-323530090352c6d1cbdef9fedda58a1ac20f7ef2.tar.gz
upstream-323530090352c6d1cbdef9fedda58a1ac20f7ef2.tar.bz2
upstream-323530090352c6d1cbdef9fedda58a1ac20f7ef2.zip
ipq-wifi: drop custom board-2.bins
The BDFs for all boards were upstreamed to the ath10k-firmware repository and linux-firmware.git. We switched to the upstream board-2.bin, hence the files can be removed here. Keep the ipq-wifi package in case new boards are added. It might take some time till board-2.bins send upstream are merged. Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/ipq40xx/image/generic.mk48
-rw-r--r--target/linux/ipq806x/image/generic.mk5
2 files changed, 20 insertions, 33 deletions
diff --git a/target/linux/ipq40xx/image/generic.mk b/target/linux/ipq40xx/image/generic.mk
index 3b0d917cd9..9dfa877c32 100644
--- a/target/linux/ipq40xx/image/generic.mk
+++ b/target/linux/ipq40xx/image/generic.mk
@@ -130,7 +130,6 @@ define Device/8dev_habanero-dvk
DEVICE_MODEL := Habanero DVK
IMAGE_SIZE := 30976k
SOC := qcom-ipq4019
- DEVICE_PACKAGES := ipq-wifi-8dev_habanero-dvk
IMAGE/sysupgrade.bin := append-kernel | pad-to 64k | append-rootfs | pad-rootfs | check-size | append-metadata
endef
TARGET_DEVICES += 8dev_habanero-dvk
@@ -169,7 +168,6 @@ define Device/aruba_glenmorangie
$(call Device/FitImageLzma)
DEVICE_VENDOR := Aruba
SOC := qcom-ipq4029
- DEVICE_PACKAGES := ipq-wifi-aruba_ap-303
endef
define Device/aruba_ap-303
@@ -187,7 +185,7 @@ TARGET_DEVICES += aruba_ap-303h
define Device/aruba_ap-365
$(call Device/aruba_glenmorangie)
DEVICE_MODEL := AP-365
- DEVICE_PACKAGES := kmod-hwmon-ad7418 ipq-wifi-aruba_ap-365
+ DEVICE_PACKAGES := kmod-hwmon-ad7418
endef
TARGET_DEVICES += aruba_ap-365
@@ -225,7 +223,7 @@ define Device/asus_rt-ac42u
# Rather, this device is a/k/a RT-AC42U
# But we'll go with what the vendor firmware has...
UIMAGE_NAME:=$(shell echo -e '\03\01\01\01RT-AC82U')
- DEVICE_PACKAGES := ath10k-firmware-qca9984-ct ipq-wifi-asus_rt-ac42u kmod-usb-ledtrig-usbport
+ DEVICE_PACKAGES := ath10k-firmware-qca9984-ct kmod-usb-ledtrig-usbport
endef
TARGET_DEVICES += asus_rt-ac42u
@@ -283,7 +281,7 @@ define Device/avm_fritzrepeater-1200
DEVICE_VENDOR := AVM
DEVICE_MODEL := FRITZ!Repeater 1200
SOC := qcom-ipq4019
- DEVICE_PACKAGES := fritz-caldata fritz-tffs-nand ipq-wifi-avm_fritzrepeater-1200
+ DEVICE_PACKAGES := fritz-caldata fritz-tffs-nand
endef
TARGET_DEVICES += avm_fritzrepeater-1200
@@ -302,7 +300,7 @@ define Device/buffalo_wtr-m2133hp
DEVICE_VENDOR := Buffalo
DEVICE_MODEL := WTR-M2133HP
SOC := qcom-ipq4019
- DEVICE_PACKAGES := ath10k-firmware-qca9984-ct ipq-wifi-buffalo_wtr-m2133hp
+ DEVICE_PACKAGES := ath10k-firmware-qca9984-ct
BLOCKSIZE := 128k
PAGESIZE := 2048
endef
@@ -326,7 +324,7 @@ define Device/cellc_rtl30vw
IMAGE_SIZE := 57344k
BLOCKSIZE := 128k
PAGESIZE := 2048
- DEVICE_PACKAGES := kmod-usb-net-qmi-wwan kmod-usb-serial-option uqmi ipq-wifi-cellc_rtl30vw
+ DEVICE_PACKAGES := kmod-usb-net-qmi-wwan kmod-usb-serial-option uqmi
endef
TARGET_DEVICES += cellc_rtl30vw
@@ -384,7 +382,6 @@ define Device/devolo_magic-2-wifi-next
IMAGE_SIZE := 26624k
IMAGES := sysupgrade.bin
IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata
- DEVICE_PACKAGES := ipq-wifi-devolo_magic-2-wifi-next
DEFAULT := n
endef
TARGET_DEVICES += devolo_magic-2-wifi-next
@@ -412,7 +409,6 @@ define Device/dlink_dap-2610
# append-rootfs must start on an erase block boundary.
IMAGE/factory.bin := append-kernel | pad-offset 6144k 160 | append-rootfs | wrgg-image | check-size
IMAGE/sysupgrade.bin := append-kernel | wrgg-image | pad-to $$$$(BLOCKSIZE) | append-rootfs | pad-rootfs | check-size | append-metadata
- DEVICE_PACKAGES := ipq-wifi-dlink_dap2610
endef
TARGET_DEVICES += dlink_dap-2610
@@ -439,7 +435,7 @@ define Device/edgecore_oap100
PAGESIZE := 2048
IMAGES := nand-sysupgrade.bin
DEVICE_DTS_CONFIG := config@ap.dk07.1-c1
- DEVICE_PACKAGES := ipq-wifi-edgecore_oap100 kmod-usb-acm kmod-usb-net kmod-usb-net-cdc-qmi uqmi
+ DEVICE_PACKAGES := kmod-usb-acm kmod-usb-net kmod-usb-net-cdc-qmi uqmi
endef
TARGET_DEVICES += edgecore_oap100
@@ -464,7 +460,7 @@ define Device/engenius_eap2200
SOC := qcom-ipq4019
BLOCKSIZE := 128k
PAGESIZE := 2048
- DEVICE_PACKAGES := ath10k-firmware-qca9888-ct ipq-wifi-engenius_eap2200 -kmod-ath10k-ct kmod-ath10k-ct-smallbuffers
+ DEVICE_PACKAGES := ath10k-firmware-qca9888-ct -kmod-ath10k-ct kmod-ath10k-ct-smallbuffers
endef
TARGET_DEVICES += engenius_eap2200
@@ -478,7 +474,6 @@ define Device/engenius_emd1
IMAGES += factory.bin
IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata
IMAGE/factory.bin := qsdk-ipq-factory-nor | check-size
- DEVICE_PACKAGES := ipq-wifi-engenius_emd1
endef
TARGET_DEVICES += engenius_emd1
@@ -493,7 +488,6 @@ define Device/engenius_emr3500
IMAGES += factory.bin
IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata
IMAGE/factory.bin := qsdk-ipq-factory-nor | check-size
- DEVICE_PACKAGES := ipq-wifi-engenius_emr3500
DEFAULT := n
endef
TARGET_DEVICES += engenius_emr3500
@@ -534,8 +528,7 @@ define Device/ezviz_cs-w3-wd1200g-eup
SOC := qcom-ipq4018
IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | \
append-metadata
- DEVICE_PACKAGES := -kmod-ath10k-ct kmod-ath10k-ct-smallbuffers \
- ipq-wifi-ezviz_cs-w3-wd1200g-eup
+ DEVICE_PACKAGES := -kmod-ath10k-ct kmod-ath10k-ct-smallbuffers
DEVICE_COMPAT_VERSION := 2.0
DEVICE_COMPAT_MESSAGE := uboot's bootcmd has to be updated (see wiki). \
Upgrade via sysupgrade mechanism is not possible.
@@ -553,7 +546,7 @@ define Device/glinet_gl-ap1300
PAGESIZE := 2048
IMAGE_SIZE := 131072k
KERNEL_INSTALL := 1
- DEVICE_PACKAGES := ipq-wifi-glinet_gl-ap1300 kmod-usb-net-qmi-wwan kmod-usb-serial-option uqmi
+ DEVICE_PACKAGES := kmod-usb-net-qmi-wwan kmod-usb-serial-option uqmi
endef
TARGET_DEVICES += glinet_gl-ap1300
@@ -582,7 +575,7 @@ define Device/glinet_gl-b2200
pad-to 33792k | append-rootfs |\
append-metadata | gzip
IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
- DEVICE_PACKAGES := ath10k-firmware-qca9888-ct ipq-wifi-glinet_gl-b2200 \
+ DEVICE_PACKAGES := ath10k-firmware-qca9888-ct \
kmod-fs-ext4 kmod-mmc kmod-spi-dev mkf2fs e2fsprogs kmod-fs-f2fs
endef
TARGET_DEVICES += glinet_gl-b2200
@@ -596,7 +589,7 @@ define Device/glinet_gl-s1300
IMAGE_SIZE := 26624k
IMAGES := sysupgrade.bin
IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata
- DEVICE_PACKAGES := ipq-wifi-glinet_gl-s1300 kmod-fs-ext4 kmod-mmc kmod-spi-dev
+ DEVICE_PACKAGES := kmod-fs-ext4 kmod-mmc kmod-spi-dev
endef
TARGET_DEVICES += glinet_gl-s1300
@@ -648,7 +641,7 @@ define Device/linksys_ea8300
UBINIZE_OPTS := -E 5 # EOD marks to "hide" factory sig at EOF
IMAGES += factory.bin
IMAGE/factory.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi | linksys-image type=EA8300
- DEVICE_PACKAGES := ath10k-firmware-qca9888-ct ipq-wifi-linksys_ea8300 kmod-usb-ledtrig-usbport
+ DEVICE_PACKAGES := ath10k-firmware-qca9888-ct kmod-usb-ledtrig-usbport
endef
TARGET_DEVICES += linksys_ea8300
@@ -664,7 +657,7 @@ define Device/linksys_mr8300
UBINIZE_OPTS := -E 5 # EOD marks to "hide" factory sig at EOF
IMAGES += factory.bin
IMAGE/factory.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi | linksys-image type=MR8300
- DEVICE_PACKAGES := ath10k-firmware-qca9888-ct ipq-wifi-linksys_mr8300-v0 kmod-usb-ledtrig-usbport
+ DEVICE_PACKAGES := ath10k-firmware-qca9888-ct kmod-usb-ledtrig-usbport
endef
TARGET_DEVICES += linksys_mr8300
@@ -673,7 +666,7 @@ define Device/luma_wrtq-329acn
DEVICE_VENDOR := Luma Home
DEVICE_MODEL := WRTQ-329ACN
SOC := qcom-ipq4018
- DEVICE_PACKAGES := ipq-wifi-luma_wrtq-329acn kmod-ath3k kmod-eeprom-at24 kmod-i2c-gpio
+ DEVICE_PACKAGES := kmod-ath3k kmod-eeprom-at24 kmod-i2c-gpio
IMAGE_SIZE := 76632k
BLOCKSIZE := 128k
PAGESIZE := 2048
@@ -699,7 +692,7 @@ define Device/mobipromo_cm520-79f
SOC := qcom-ipq4019
BLOCKSIZE := 128k
PAGESIZE := 2048
- DEVICE_PACKAGES := ipq-wifi-mobipromo_cm520-79f kmod-usb-ledtrig-usbport
+ DEVICE_PACKAGES := kmod-usb-ledtrig-usbport
endef
TARGET_DEVICES += mobipromo_cm520-79f
@@ -840,7 +833,6 @@ define Device/p2w_r619ac
DEVICE_DTS_CONFIG := config@10
BLOCKSIZE := 128k
PAGESIZE := 2048
- DEVICE_PACKAGES := ipq-wifi-p2w_r619ac
endef
define Device/p2w_r619ac-64m
@@ -869,7 +861,6 @@ define Device/plasmacloud_pa1200
IMAGES += factory.bin
IMAGE/factory.bin := append-rootfs | pad-rootfs | openmesh-image ce_type=PA1200
IMAGE/sysupgrade.bin/squashfs := append-rootfs | pad-rootfs | sysupgrade-tar rootfs=$$$$@ | append-metadata
- DEVICE_PACKAGES := ipq-wifi-plasmacloud_pa1200
endef
TARGET_DEVICES += plasmacloud_pa1200
@@ -885,7 +876,7 @@ define Device/plasmacloud_pa2200
IMAGES += factory.bin
IMAGE/factory.bin := append-rootfs | pad-rootfs | openmesh-image ce_type=PA2200
IMAGE/sysupgrade.bin/squashfs := append-rootfs | pad-rootfs | sysupgrade-tar rootfs=$$$$@ | append-metadata
- DEVICE_PACKAGES := ath10k-firmware-qca9888-ct ipq-wifi-plasmacloud_pa2200
+ DEVICE_PACKAGES := ath10k-firmware-qca9888-ct
endef
TARGET_DEVICES += plasmacloud_pa2200
@@ -932,7 +923,6 @@ define Device/qxwlan_e2600ac-c1
KERNEL_SIZE := 4096k
IMAGE_SIZE := 31232k
IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata
- DEVICE_PACKAGES := ipq-wifi-qxwlan_e2600ac-c1
DEFAULT := n
endef
TARGET_DEVICES += qxwlan_e2600ac-c1
@@ -947,7 +937,6 @@ define Device/qxwlan_e2600ac-c2
KERNEL_INSTALL := 1
BLOCKSIZE := 128k
PAGESIZE := 2048
- DEVICE_PACKAGES := ipq-wifi-qxwlan_e2600ac-c2
endef
TARGET_DEVICES += qxwlan_e2600ac-c2
@@ -963,7 +952,7 @@ define Device/teltonika_rutx10
PAGESIZE := 2048
FILESYSTEMS := squashfs
IMAGE/nand-factory.ubi := append-ubi | qsdk-ipq-factory-nand | append-rutx-metadata
- DEVICE_PACKAGES := ipq-wifi-teltonika_rutx kmod-bluetooth
+ DEVICE_PACKAGES := kmod-bluetooth
endef
TARGET_DEVICES += teltonika_rutx10
@@ -1008,14 +997,13 @@ endef
define Device/zte_mf286d
$(call Device/zte_mf28x_common)
DEVICE_MODEL := MF286D
- DEVICE_PACKAGES += ipq-wifi-zte_mf286d
endef
TARGET_DEVICES += zte_mf286d
define Device/zte_mf289f
$(call Device/zte_mf28x_common)
DEVICE_MODEL := MF289F
- DEVICE_PACKAGES += ipq-wifi-zte_mf289f ath10k-firmware-qca9984-ct
+ DEVICE_PACKAGES += ath10k-firmware-qca9984-ct
endef
TARGET_DEVICES += zte_mf289f
diff --git a/target/linux/ipq806x/image/generic.mk b/target/linux/ipq806x/image/generic.mk
index 469f2c654e..41820cdd97 100644
--- a/target/linux/ipq806x/image/generic.mk
+++ b/target/linux/ipq806x/image/generic.mk
@@ -141,8 +141,7 @@ define Device/edgecore_ecw5410
BLOCKSIZE := 128k
PAGESIZE := 2048
DEVICE_DTS_CONFIG := config@v2.0-ap160
- DEVICE_PACKAGES := ath10k-firmware-qca9984-ct \
- ipq-wifi-edgecore_ecw5410
+ DEVICE_PACKAGES := ath10k-firmware-qca9984-ct
endef
TARGET_DEVICES += edgecore_ecw5410
@@ -247,7 +246,7 @@ define Device/nec_wg2600hp3
DEVICE_PACKAGES := -kmod-ata-ahci -kmod-ata-ahci-platform \
-kmod-usb-ohci -kmod-usb2 -kmod-usb-ledtrig-usbport \
-kmod-usb-phy-qcom-dwc3 -kmod-usb3 -kmod-usb-dwc3-qcom \
- ath10k-firmware-qca9984-ct ipq-wifi-nec_wg2600hp3
+ ath10k-firmware-qca9984-ct
endef
TARGET_DEVICES += nec_wg2600hp3