aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-12-09 14:26:12 +0100
committerFelix Fietkau <nbd@nbd.name>2016-12-12 10:22:18 +0100
commit30285facbe3769ca508c865638c4ee2238270fbe (patch)
tree1ad78946ffce3b0f23e40c07e4d216bf4ce60395 /target/linux
parent4c8a9b8e39aed5cdb0eeaf73d59ccdffd927e522 (diff)
downloadupstream-30285facbe3769ca508c865638c4ee2238270fbe.tar.gz
upstream-30285facbe3769ca508c865638c4ee2238270fbe.tar.bz2
upstream-30285facbe3769ca508c865638c4ee2238270fbe.zip
ar71xx: remove AP113 reference design board support
Due to flash size limitations, support for this board has not been functional for years Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'target/linux')
-rwxr-xr-xtarget/linux/ar71xx/base-files/etc/board.d/01_leds1
-rwxr-xr-xtarget/linux/ar71xx/base-files/etc/board.d/02_network1
-rw-r--r--target/linux/ar71xx/base-files/etc/uci-defaults/03_network-switchX-migration1
-rwxr-xr-xtarget/linux/ar71xx/base-files/lib/ar71xx.sh3
-rwxr-xr-xtarget/linux/ar71xx/base-files/lib/upgrade/platform.sh1
-rw-r--r--target/linux/ar71xx/config-4.41
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt10
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/Makefile1
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/mach-ap113.c84
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/machtypes.h1
-rw-r--r--target/linux/ar71xx/mikrotik/config-default1
-rw-r--r--target/linux/ar71xx/nand/config-default1
12 files changed, 0 insertions, 106 deletions
diff --git a/target/linux/ar71xx/base-files/etc/board.d/01_leds b/target/linux/ar71xx/base-files/etc/board.d/01_leds
index 38e665fb64..dcdaab022d 100755
--- a/target/linux/ar71xx/base-files/etc/board.d/01_leds
+++ b/target/linux/ar71xx/base-files/etc/board.d/01_leds
@@ -45,7 +45,6 @@ arduino-yun)
ucidef_set_led_wlan "wlan" "WLAN" "arduino:blue:wlan" "phy0tpt"
ucidef_set_led_usbdev "usb" "USB" "arduino:white:usb" "1-1.1"
;;
-ap113|\
db120)
ucidef_set_led_usbdev "usb" "USB" "$board:green:usb" "1-1"
;;
diff --git a/target/linux/ar71xx/base-files/etc/board.d/02_network b/target/linux/ar71xx/base-files/etc/board.d/02_network
index f287d4bff2..440e00f5bf 100755
--- a/target/linux/ar71xx/base-files/etc/board.d/02_network
+++ b/target/linux/ar71xx/base-files/etc/board.d/02_network
@@ -146,7 +146,6 @@ ar71xx_setup_interfaces()
ubnt-unifi-outdoor)
ucidef_set_interface_lan "eth0 eth1"
;;
- ap113|\
pb92|\
wzr-hp-g300nh2)
ucidef_add_switch "switch0" \
diff --git a/target/linux/ar71xx/base-files/etc/uci-defaults/03_network-switchX-migration b/target/linux/ar71xx/base-files/etc/uci-defaults/03_network-switchX-migration
index c6b91b7737..c67555f963 100644
--- a/target/linux/ar71xx/base-files/etc/uci-defaults/03_network-switchX-migration
+++ b/target/linux/ar71xx/base-files/etc/uci-defaults/03_network-switchX-migration
@@ -48,7 +48,6 @@ case "$board" in
dir-825-c1|\
wzr-hp-g300nh2|\
pb92|\
-ap113|\
tl-wdr4300|\
tl-wr1041n-v2|\
wrt160nl|\
diff --git a/target/linux/ar71xx/base-files/lib/ar71xx.sh b/target/linux/ar71xx/base-files/lib/ar71xx.sh
index ffab8ebbc4..cf84dadf04 100755
--- a/target/linux/ar71xx/base-files/lib/ar71xx.sh
+++ b/target/linux/ar71xx/base-files/lib/ar71xx.sh
@@ -435,9 +435,6 @@ ar71xx_board_detect() {
*"Arduino Yun")
name="arduino-yun"
;;
- *AP113)
- name="ap113"
- ;;
*"AP121 reference board")
name="ap121"
;;
diff --git a/target/linux/ar71xx/base-files/lib/upgrade/platform.sh b/target/linux/ar71xx/base-files/lib/upgrade/platform.sh
index 0100d27211..b028cd35a8 100755
--- a/target/linux/ar71xx/base-files/lib/upgrade/platform.sh
+++ b/target/linux/ar71xx/base-files/lib/upgrade/platform.sh
@@ -261,7 +261,6 @@ platform_check_image() {
;;
alfa-ap96|\
alfa-nx|\
- ap113|\
ap121-mini|\
ap121|\
ap135-020|\
diff --git a/target/linux/ar71xx/config-4.4 b/target/linux/ar71xx/config-4.4
index e83e668747..5e0275aa06 100644
--- a/target/linux/ar71xx/config-4.4
+++ b/target/linux/ar71xx/config-4.4
@@ -40,7 +40,6 @@ CONFIG_ATH79_MACH_ALL0315N=y
CONFIG_ATH79_MACH_ANTMINER_S1=y
CONFIG_ATH79_MACH_ANTMINER_S3=y
CONFIG_ATH79_MACH_ANTROUTER_R1=y
-CONFIG_ATH79_MACH_AP113=y
CONFIG_ATH79_MACH_AP121=y
CONFIG_ATH79_MACH_AP132=y
CONFIG_ATH79_MACH_AP136=y
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt b/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
index a0f24e16b5..4d82db2c76 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
+++ b/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
@@ -103,16 +103,6 @@ config ATH79_MACH_ARDUINO_YUN
Say 'Y' here if you want your kernel to support the
Arduino Yun.
-config ATH79_MACH_AP113
- bool "Atheros AP113 board support"
- select SOC_AR724X
- select ATH79_DEV_M25P80
- select ATH79_DEV_PB9X_PCI if PCI
- select ATH79_DEV_GPIO_BUTTONS
- select ATH79_DEV_LEDS_GPIO
- select ATH79_DEV_USB
- select ATH79_DEV_ETH
-
config ATH79_MACH_AP132
bool "Atheros AP132 reference board"
select SOC_QCA955X
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/Makefile b/target/linux/ar71xx/files/arch/mips/ath79/Makefile
index 03ca101906..a39e8d2de7 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/Makefile
+++ b/target/linux/ar71xx/files/arch/mips/ath79/Makefile
@@ -46,7 +46,6 @@ obj-$(CONFIG_ATH79_MACH_ALL0315N) += mach-all0315n.o
obj-$(CONFIG_ATH79_MACH_ANTMINER_S1) += mach-antminer-s1.o
obj-$(CONFIG_ATH79_MACH_ANTMINER_S3) += mach-antminer-s3.o
obj-$(CONFIG_ATH79_MACH_ANTROUTER_R1) += mach-antrouter-r1.o
-obj-$(CONFIG_ATH79_MACH_AP113) += mach-ap113.o
obj-$(CONFIG_ATH79_MACH_AP121) += mach-ap121.o
obj-$(CONFIG_ATH79_MACH_AP132) += mach-ap132.o
obj-$(CONFIG_ATH79_MACH_AP136) += mach-ap136.o
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/mach-ap113.c b/target/linux/ar71xx/files/arch/mips/ath79/mach-ap113.c
deleted file mode 100644
index 9b38faa47c..0000000000
--- a/target/linux/ar71xx/files/arch/mips/ath79/mach-ap113.c
+++ /dev/null
@@ -1,84 +0,0 @@
-/*
- * Atheros AP113 board support
- *
- * Copyright (C) 2011 Florian Fainelli <florian@openwrt.org>
- *
- * This program is free software; you can redistribute it and/or modify it
- * under the terms of the GNU General Public License version 2 as published
- * by the Free Software Foundation.
- */
-
-#include "dev-eth.h"
-#include "dev-gpio-buttons.h"
-#include "dev-leds-gpio.h"
-#include "dev-m25p80.h"
-#include "pci.h"
-#include "dev-usb.h"
-#include "machtypes.h"
-
-#define AP113_GPIO_LED_USB 0
-#define AP113_GPIO_LED_STATUS 1
-#define AP113_GPIO_LED_ST 11
-
-#define AP113_GPIO_BTN_JUMPSTART 12
-
-#define AP113_KEYS_POLL_INTERVAL 20 /* msecs */
-#define AP113_KEYS_DEBOUNCE_INTERVAL (3 * AP113_KEYS_POLL_INTERVAL)
-
-static struct gpio_led ap113_leds_gpio[] __initdata = {
- {
- .name = "ap113:green:usb",
- .gpio = AP113_GPIO_LED_USB,
- .active_low = 1,
- },
- {
- .name = "ap113:green:status",
- .gpio = AP113_GPIO_LED_STATUS,
- .active_low = 1,
- },
- {
- .name = "ap113:green:st",
- .gpio = AP113_GPIO_LED_ST,
- .active_low = 1,
- }
-};
-
-static struct gpio_keys_button ap113_gpio_keys[] __initdata = {
- {
- .desc = "jumpstart button",
- .type = EV_KEY,
- .code = KEY_WPS_BUTTON,
- .debounce_interval = AP113_KEYS_DEBOUNCE_INTERVAL,
- .gpio = AP113_GPIO_BTN_JUMPSTART,
- .active_low = 1,
- },
-};
-
-static void __init ap113_setup(void)
-{
- u8 *mac = (u8 *) KSEG1ADDR(0x1fff0000);
-
- ath79_register_m25p80(NULL);
-
- ath79_register_mdio(0, ~BIT(0));
- ath79_init_mac(ath79_eth0_data.mac_addr, mac, 0);
- ath79_eth0_data.phy_if_mode = PHY_INTERFACE_MODE_RGMII;
- ath79_eth0_data.speed = SPEED_1000;
- ath79_eth0_data.duplex = DUPLEX_FULL;
- ath79_eth0_data.phy_mask = BIT(0);
-
- ath79_register_eth(0);
-
- ath79_register_gpio_keys_polled(-1, AP113_KEYS_POLL_INTERVAL,
- ARRAY_SIZE(ap113_gpio_keys),
- ap113_gpio_keys);
- ath79_register_leds_gpio(-1, ARRAY_SIZE(ap113_leds_gpio),
- ap113_leds_gpio);
-
- ath79_register_pci();
-
- ath79_register_usb();
-}
-
-MIPS_MACHINE(ATH79_MACH_AP113, "AP113", "Atheros AP113",
- ap113_setup);
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h b/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
index cd26598770..5893790c61 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
+++ b/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
@@ -26,7 +26,6 @@ enum ath79_mach_type {
ATH79_MACH_ANTMINER_S1, /* Antminer S1 */
ATH79_MACH_ANTMINER_S3, /* Antminer S3 */
ATH79_MACH_ANTROUTER_R1, /* Antrouter R1 */
- ATH79_MACH_AP113, /* Atheros AP113 reference board */
ATH79_MACH_AP121, /* Atheros AP121 reference board */
ATH79_MACH_AP121_MINI, /* Atheros AP121-MINI reference board */
ATH79_MACH_AP132, /* Atheros AP132 reference board */
diff --git a/target/linux/ar71xx/mikrotik/config-default b/target/linux/ar71xx/mikrotik/config-default
index 3d5d20daed..aa898ee827 100644
--- a/target/linux/ar71xx/mikrotik/config-default
+++ b/target/linux/ar71xx/mikrotik/config-default
@@ -4,7 +4,6 @@
# CONFIG_ATH79_MACH_ALL0258N is not set
# CONFIG_ATH79_MACH_ALL0315N is not set
# CONFIG_ATH79_MACH_ANTMINER_S1 is not set
-# CONFIG_ATH79_MACH_AP113 is not set
# CONFIG_ATH79_MACH_AP121 is not set
# CONFIG_ATH79_MACH_AP132 is not set
# CONFIG_ATH79_MACH_AP136 is not set
diff --git a/target/linux/ar71xx/nand/config-default b/target/linux/ar71xx/nand/config-default
index 1c3a650c39..49480f2be8 100644
--- a/target/linux/ar71xx/nand/config-default
+++ b/target/linux/ar71xx/nand/config-default
@@ -3,7 +3,6 @@
# CONFIG_ATH79_MACH_ALFA_NX is not set
# CONFIG_ATH79_MACH_ALL0258N is not set
# CONFIG_ATH79_MACH_ALL0315N is not set
-# CONFIG_ATH79_MACH_AP113 is not set
# CONFIG_ATH79_MACH_AP121 is not set
# CONFIG_ATH79_MACH_AP132 is not set
# CONFIG_ATH79_MACH_AP136 is not set