aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorClaudio Leite <leitec@gmail.com>2017-02-05 03:59:45 -0500
committerJohn Crispin <john@phrozen.org>2017-02-09 09:14:45 +0100
commit290ca2ba46d9cf2c71c0ef636f4e2e2246cabae5 (patch)
tree6dd80fa9c472ef2bea8a8ce23e39f8c460cc86e5 /target/linux
parent76eb62e5afeac6ca5d90fb26eb34ac66df91a82e (diff)
downloadupstream-290ca2ba46d9cf2c71c0ef636f4e2e2246cabae5.tar.gz
upstream-290ca2ba46d9cf2c71c0ef636f4e2e2246cabae5.tar.bz2
upstream-290ca2ba46d9cf2c71c0ef636f4e2e2246cabae5.zip
ramips: fix AR670W partition alignment
mtdsplit_lzma requires that the rootfs be aligned to a block boundary. Pad the kernel partition to make this so. Signed-off-by: Claudio Leite <leitec@gmail.com>
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/ramips/image/rt288x.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/ramips/image/rt288x.mk b/target/linux/ramips/image/rt288x.mk
index 4a0d6d4ae7..86a506388c 100644
--- a/target/linux/ramips/image/rt288x.mk
+++ b/target/linux/ramips/image/rt288x.mk
@@ -14,7 +14,7 @@ define Device/ar670w
BLOCKSIZE := 64k
DEVICE_TITLE := Airlink AR670W
IMAGE_SIZE := $(ralink_default_fw_size_4M)
- KERNEL := $(KERNEL_DTB)
+ KERNEL := $(KERNEL_DTB) | pad-to $$(BLOCKSIZE)
IMAGES += factory.bin
IMAGE/factory.bin := $$(sysupgrade_bin) | check-size $$$$(IMAGE_SIZE) | \
wrg-header wrgn16a_airlink_ar670w