aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorWill Moss <willormos@gmail.com>2022-11-10 19:55:11 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2022-11-27 15:43:08 +0100
commit0b22e87db0db1a232714657e2f44a83450f8caf7 (patch)
treef7f261df2c58cf5deb1c96afb1d0279d488d654b /target/linux
parentde6c3cca4d2b523937403ae2959597a1e48c7351 (diff)
downloadupstream-0b22e87db0db1a232714657e2f44a83450f8caf7.tar.gz
upstream-0b22e87db0db1a232714657e2f44a83450f8caf7.tar.bz2
upstream-0b22e87db0db1a232714657e2f44a83450f8caf7.zip
ath79: D-Link DIR-825 B1 add factory.bin recipe
- Bring back factory.bin image which was missing after porting device to ath79 target - Use default sysupgrade.bin image recipe - Adjust max image size according to new firmware partition size after "ath79: expand rootfs for DIR-825-B1 with unused space (aca8bb5)" changes - Remove support of upgrading from version 19.07, because partition size changes mentioned above Signed-off-by: Will Moss <willormos@gmail.com> (cherry picked from commit a58146d452c50387256d4a616c055ddf3248496f)
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/ath79/image/generic.mk10
1 files changed, 6 insertions, 4 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index d088f91019..31d296fb62 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -969,12 +969,14 @@ define Device/dlink_dir-825-b1
DEVICE_VENDOR := D-Link
DEVICE_MODEL := DIR-825
DEVICE_VARIANT := B1
- IMAGE_SIZE := 6208k
- IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | \
- check-size | append-metadata
DEVICE_PACKAGES := kmod-usb-ohci kmod-usb2 kmod-usb-ledtrig-usbport \
kmod-leds-reset kmod-owl-loader
- SUPPORTED_DEVICES += dir-825-b1
+ IMAGE_SIZE := 7808k
+ FACTORY_SIZE := 6144k
+ IMAGES += factory.bin
+ IMAGE/factory.bin = append-kernel | pad-to $$$$(BLOCKSIZE) | append-rootfs | \
+ pad-rootfs | check-size $$$$(FACTORY_SIZE) | pad-to $$$$(FACTORY_SIZE) | \
+ append-string 01AP94-AR7161-RT-080619-00
endef
TARGET_DEVICES += dlink_dir-825-b1