aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorINAGAKI Hiroshi <musashino.open@gmail.com>2020-04-28 23:45:41 +0900
committerChuanhong Guo <gch981213@gmail.com>2020-05-19 19:03:07 +0800
commit0a05d71f6f34d2e9101fa40e9643d4f7bc8e7501 (patch)
treef4c2da541e8cfd0fd3c61a0c7c9df074d5d8e236 /target/linux
parenta43cbfe2e3a11cbba3f0e92edb96f12531352825 (diff)
downloadupstream-0a05d71f6f34d2e9101fa40e9643d4f7bc8e7501.tar.gz
upstream-0a05d71f6f34d2e9101fa40e9643d4f7bc8e7501.tar.bz2
upstream-0a05d71f6f34d2e9101fa40e9643d4f7bc8e7501.zip
ramips: fix initramfs image for I-O DATA mt7621 devices
This is additional fix of c998ae7f0e9bd51be4935055efbc3834a92698b1. The sysupgrade image of I-O DATA MT7621 devices manufactured by MSTC (MitraStar Technology Corp.) faced to the booting issue. This was caused by imcomplete extraction of large kernel image by U-Boot, and this issue is occurred in initramfs image after fixing of sysupgrade image. So, use lzma-loader for initramfs image to fix the issue. Signed-off-by: INAGAKI Hiroshi <musashino.open@gmail.com> Co-developed-by: Yanase Yuki <dev@zpc.sakura.ne.jp> Signed-off-by: Yanase Yuki <dev@zpc.sakura.ne.jp> Tested-by: Yanase Yuki <dev@zpc.sakura.ne.jp> [wn-ax2033gr]
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/ramips/image/mt7621.mk12
1 files changed, 6 insertions, 6 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index e3ded2ebc2..94fc85ed1a 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -380,8 +380,8 @@ define Device/iodata_wn-ax1167gr2
$(Device/iodata_nand)
UIMAGE_MAGIC := 0x434f4d42
DEVICE_MODEL := WN-AX1167GR2
- KERNEL_INITRAMFS := $(KERNEL_DTB) | custom-initramfs-uimage 3.10(XBC.1)b10 | \
- iodata-mstc-header
+ KERNEL_INITRAMFS := $(KERNEL_DTB) | loader-kernel | lzma | \
+ custom-initramfs-uimage 3.10(XBC.1)b10 | iodata-mstc-header
DEVICE_PACKAGES := kmod-mt7615e wpad-basic
endef
TARGET_DEVICES += iodata_wn-ax1167gr2
@@ -390,8 +390,8 @@ define Device/iodata_wn-ax2033gr
$(Device/iodata_nand)
UIMAGE_MAGIC := 0x434f4d42
DEVICE_MODEL := WN-AX2033GR
- KERNEL_INITRAMFS := $(KERNEL_DTB) | custom-initramfs-uimage 3.10(VST.1)C10 | \
- iodata-mstc-header
+ KERNEL_INITRAMFS := $(KERNEL_DTB) | loader-kernel | lzma | \
+ custom-initramfs-uimage 3.10(VST.1)C10 | iodata-mstc-header
DEVICE_PACKAGES := kmod-mt7603 kmod-mt7615e wpad-basic
endef
TARGET_DEVICES += iodata_wn-ax2033gr
@@ -400,8 +400,8 @@ define Device/iodata_wn-dx1167r
$(Device/iodata_nand)
UIMAGE_MAGIC := 0x434f4d43
DEVICE_MODEL := WN-DX1167R
- KERNEL_INITRAMFS := $(KERNEL_DTB) | custom-initramfs-uimage 3.10(XIK.1)b10 | \
- iodata-mstc-header
+ KERNEL_INITRAMFS := $(KERNEL_DTB) | loader-kernel | lzma | \
+ custom-initramfs-uimage 3.10(XIK.1)b10 | iodata-mstc-header
DEVICE_PACKAGES := kmod-mt7615e wpad-basic
endef
TARGET_DEVICES += iodata_wn-dx1167r