aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorPiotr Dymacz <pepe2k@gmail.com>2018-01-15 13:30:19 +0100
committerPiotr Dymacz <pepe2k@gmail.com>2018-01-15 13:39:54 +0100
commit030176e0e798227bf8c94d9c0bceb1a6e46697d8 (patch)
tree4c8486234c897b6c46c3a2f1f8b330f0a22786cf /target/linux
parentebd15471ea4f0502e2fe4e77351cb3cb8867142d (diff)
downloadupstream-030176e0e798227bf8c94d9c0bceb1a6e46697d8.tar.gz
upstream-030176e0e798227bf8c94d9c0bceb1a6e46697d8.tar.bz2
upstream-030176e0e798227bf8c94d9c0bceb1a6e46697d8.zip
ar71xx: image: rework EnGenius ENS202EXT factory image
Current EnGenius ENS202EXT factory image recipe version causes factory images of the following devices to be corrupted. This issue wasn't visible until recent changes of image Makefile snippets order. Signed-off-by: Mathias Kresin <dev@kresin.me> Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/ar71xx/image/generic-senao.mk11
1 files changed, 4 insertions, 7 deletions
diff --git a/target/linux/ar71xx/image/generic-senao.mk b/target/linux/ar71xx/image/generic-senao.mk
index dbb7b69f94..3a7f6776b3 100644
--- a/target/linux/ar71xx/image/generic-senao.mk
+++ b/target/linux/ar71xx/image/generic-senao.mk
@@ -1,12 +1,9 @@
define Build/senao-factory-image
- $(eval board=$(word 1,$(1)))
- $(eval rootfs=$(word 2,$(1)))
-
mkdir -p $@.senao
- touch $@.senao/FWINFO-OpenWrt-$(REVISION)-$(board)
- $(CP) $(IMAGE_KERNEL) $@.senao/openwrt-senao-$(board)-uImage-lzma.bin
- $(CP) $(rootfs) $@.senao/openwrt-senao-$(board)-root.squashfs
+ touch $@.senao/FWINFO-OpenWrt-$(REVISION)-$(1)
+ $(CP) $(IMAGE_KERNEL) $@.senao/openwrt-senao-$(1)-uImage-lzma.bin
+ $(CP) $@ $@.senao/openwrt-senao-$(1)-root.squashfs
$(TAR) -c \
--numeric-owner --owner=0 --group=0 --sort=name \
@@ -25,7 +22,7 @@ define Device/ens202ext
IMAGE_SIZE := 13632k
IMAGES += factory.bin
MTDPARTS := spi0.0:256k(u-boot)ro,64k(u-boot-env),320k(custom)ro,1536k(kernel),12096k(rootfs),2048k(failsafe)ro,64k(art)ro,13632k@0xa0000(firmware)
- IMAGE/factory.bin/squashfs := append-rootfs | pad-rootfs | senao-factory-image ens202ext $$$$@
+ IMAGE/factory.bin := append-rootfs | pad-rootfs | senao-factory-image ens202ext
IMAGE/sysupgrade.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE)
endef
TARGET_DEVICES += ens202ext