aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/zynq
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-01-18 02:21:14 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-01-21 14:26:04 +0100
commit2cb413de1c97777e4375eace8c863f91b2c0452d (patch)
tree8c52a3a92e99bf111cc2063ea7ee13b6637180eb /target/linux/zynq
parent1fa04b5d9fb1cba56a8597d6da9e1d52b8030f6b (diff)
downloadupstream-2cb413de1c97777e4375eace8c863f91b2c0452d.tar.gz
upstream-2cb413de1c97777e4375eace8c863f91b2c0452d.tar.bz2
upstream-2cb413de1c97777e4375eace8c863f91b2c0452d.zip
zynq: derive DEVICE_DTS from device definition name
In zynq target, the DEVICE_DTS variable is always set consistent with the model part of the device definition name. This patch replaces the redundant definitions for the individual devices with a common recipe. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/zynq')
-rw-r--r--target/linux/zynq/image/Makefile5
1 files changed, 1 insertions, 4 deletions
diff --git a/target/linux/zynq/image/Makefile b/target/linux/zynq/image/Makefile
index 39305a6d54..7cec38ca68 100644
--- a/target/linux/zynq/image/Makefile
+++ b/target/linux/zynq/image/Makefile
@@ -31,6 +31,7 @@ endef
define Device/Default
PROFILES := Default
+ DEVICE_DTS := $(lastword $(subst _, ,$(1)))
KERNEL_DEPENDS = $$(wildcard $(DTS_DIR)/$$(DEVICE_DTS).dts)
KERNEL_INITRAMFS_PREFIX := $$(IMG_PREFIX)-$(1)-initramfs
KERNEL_PREFIX := $$(IMAGE_PREFIX)
@@ -53,7 +54,6 @@ define Device/avnet_zynq-zed
$(call Device/FitImageGzip)
DEVICE_VENDOR := Avnet
DEVICE_MODEL := ZedBoard
- DEVICE_DTS := zynq-zed
endef
TARGET_DEVICES += avnet_zynq-zed
@@ -61,7 +61,6 @@ define Device/digilent_zynq-zybo
$(call Device/FitImageGzip)
DEVICE_VENDOR := Digilent
DEVICE_MODEL := Zybo
- DEVICE_DTS := zynq-zybo
endef
TARGET_DEVICES += digilent_zynq-zybo
@@ -69,7 +68,6 @@ define Device/digilent_zynq-zybo-z7
$(call Device/FitImageGzip)
DEVICE_VENDOR := Digilent
DEVICE_MODEL := Zybo Z7
- DEVICE_DTS := zynq-zybo-z7
endef
TARGET_DEVICES += digilent_zynq-zybo-z7
@@ -77,7 +75,6 @@ define Device/xlnx_zynq-zc702
$(call Device/FitImageGzip)
DEVICE_VENDOR := Xilinx
DEVICE_MODEL := ZC702
- DEVICE_DTS := zynq-zc702
DEVICE_PACKAGES:=kmod-can kmod-can-xilinx-can
endef
TARGET_DEVICES += xlnx_zynq-zc702