aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86
diff options
context:
space:
mode:
authorFlorian Eckert <fe@dev.tdt.de>2019-07-02 12:04:58 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2020-06-26 20:54:53 +0200
commitf3c5c09e5ad6671519c6a3b29f9c6adb7fff66cb (patch)
treee9e22dc929aea01ae7f37921f723032f6028a6bc /target/linux/x86
parent97bc87d81a98dc0597b6492017cef9098cc9c012 (diff)
downloadupstream-f3c5c09e5ad6671519c6a3b29f9c6adb7fff66cb.tar.gz
upstream-f3c5c09e5ad6671519c6a3b29f9c6adb7fff66cb.tar.bz2
upstream-f3c5c09e5ad6671519c6a3b29f9c6adb7fff66cb.zip
kernel: add pcengines-apu2 module description
Add a module description for the new pcengnies-apu2 device driver. This driver supports the front button and LEDs on the PC Engines APUv2/APUv3 boards. Signed-off-by: Florian Eckert <fe@dev.tdt.de>
Diffstat (limited to 'target/linux/x86')
-rw-r--r--target/linux/x86/modules.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/target/linux/x86/modules.mk b/target/linux/x86/modules.mk
index c8722938d3..61ab400dc9 100644
--- a/target/linux/x86/modules.mk
+++ b/target/linux/x86/modules.mk
@@ -34,3 +34,20 @@ define KernelPackage/sp5100-tco/description
endef
$(eval $(call KernelPackage,sp5100-tco))
+
+
+define KernelPackage/pcengines-apuv2
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=PC Engines APUv2/3 front button and LEDs driver
+ DEPENDS:=@TARGET_x86 +kmod-gpio-amd-fch +kmod-leds-gpio
+ KCONFIG:=CONFIG_PCENGINES_APU2
+ FILES:=$(LINUX_DIR)/drivers/platform/x86/pcengines-apuv2.ko
+ AUTOLOAD:=$(call AutoLoad,60,pcengines-apuv2)
+endef
+
+define KernelPackage/pcengines-apuv2/description
+ This driver provides support for the front button and LEDs on
+ PC Engines APUv2/APUv3 board.
+endef
+
+$(eval $(call KernelPackage,pcengines-apuv2))