aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2022-03-28 12:29:04 +0200
committerPetr Štetiar <ynezz@true.cz>2022-03-29 12:02:50 +0200
commitbe9a69caa826dad7e054c2c7b0ea14e3864c19bb (patch)
treed598e48a10d4b6292c9272271c166293f16cd67f /target/linux/x86
parent12c33d99c8b37013cfe9cb36a65de08a076a6ec3 (diff)
downloadupstream-be9a69caa826dad7e054c2c7b0ea14e3864c19bb.tar.gz
upstream-be9a69caa826dad7e054c2c7b0ea14e3864c19bb.tar.bz2
upstream-be9a69caa826dad7e054c2c7b0ea14e3864c19bb.zip
kernel: modules: fix kmod-mdio-devres dependency for 5.15
Fixes following build issues: Package kmod-r8169 is missing dependencies for the following libraries: mdio_devres.ko Package kmod-ixgbe is missing dependencies for the following libraries: mdio_devres.ko Package kmod-amd-xgbe is missing dependencies for the following libraries: mdio_devres.ko Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'target/linux/x86')
-rw-r--r--target/linux/x86/modules.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/x86/modules.mk b/target/linux/x86/modules.mk
index f3226e3a60..fcf8dfcdff 100644
--- a/target/linux/x86/modules.mk
+++ b/target/linux/x86/modules.mk
@@ -22,7 +22,7 @@ $(eval $(call KernelPackage,amazon-ena))
define KernelPackage/amd-xgbe
SUBMENU:=$(NETWORK_DEVICES_MENU)
TITLE:=AMD Ethernet on SoC support
- DEPENDS:=@PCI_SUPPORT @TARGET_x86_64 +kmod-lib-crc32c +kmod-ptp +kmod-libphy +LINUX_5_10:kmod-mdio-devres
+ DEPENDS:=@PCI_SUPPORT @TARGET_x86_64 +kmod-lib-crc32c +kmod-ptp +kmod-libphy +(LINUX_5_10||LINUX_5_15):kmod-mdio-devres
KCONFIG:=CONFIG_AMD_XGBE
FILES:=$(LINUX_DIR)/drivers/net/ethernet/amd/xgbe/amd-xgbe.ko
AUTOLOAD:=$(call AutoLoad,35,amd-xgbe)