aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2020-03-20 00:10:56 -1000
committerDaniel Golle <daniel@makrotopia.org>2020-03-21 10:36:00 +0000
commitb2207e267b5971fbd92a7a9edd5ecdcd0d362603 (patch)
tree2a8820eafdd7339e27cd8bdcc4133f173f669fa8 /target/linux/x86
parentcb007a7bf6199ebca89f79c8ee5f9b1807a0c5b0 (diff)
downloadupstream-b2207e267b5971fbd92a7a9edd5ecdcd0d362603.tar.gz
upstream-b2207e267b5971fbd92a7a9edd5ecdcd0d362603.tar.bz2
upstream-b2207e267b5971fbd92a7a9edd5ecdcd0d362603.zip
x86: remove obsolete legacy profiles
Rely on device profiles instead for packages selection. Signed-off-by: Tomasz Maciej Nowak <tomek_n@o2.pl> [rebase, adjusted commit title] Signed-off-by: Paul Spooren <mail@aparcar.org>
Diffstat (limited to 'target/linux/x86')
-rw-r--r--target/linux/x86/64/profiles/000-Generic.mk15
-rw-r--r--target/linux/x86/generic/profiles/000-Generic.mk19
-rw-r--r--target/linux/x86/geode/profiles/000-Generic.mk20
-rw-r--r--target/linux/x86/geode/profiles/100-Geos.mk19
-rw-r--r--target/linux/x86/legacy/profiles/000-Generic.mk18
5 files changed, 0 insertions, 91 deletions
diff --git a/target/linux/x86/64/profiles/000-Generic.mk b/target/linux/x86/64/profiles/000-Generic.mk
deleted file mode 100644
index b5b10c4ade..0000000000
--- a/target/linux/x86/64/profiles/000-Generic.mk
+++ /dev/null
@@ -1,15 +0,0 @@
-#
-# Copyright (C) 2006-2019 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Generic
- NAME:=Generic x86/64
-endef
-
-define Profile/Generic/Description
- Generic Profile for x86/64 architecture
-endef
-$(eval $(call Profile,Generic))
diff --git a/target/linux/x86/generic/profiles/000-Generic.mk b/target/linux/x86/generic/profiles/000-Generic.mk
deleted file mode 100644
index 7717131be0..0000000000
--- a/target/linux/x86/generic/profiles/000-Generic.mk
+++ /dev/null
@@ -1,19 +0,0 @@
-#
-# Copyright (C) 2006-2019 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Generic
- NAME:=Generic x86
- PACKAGES:=kmod-e1000e kmod-igb kmod-bnx2 \
- kmod-3c59x kmod-e100 kmod-e1000 kmod-natsemi kmod-ne2k-pci \
- kmod-pcnet32 kmod-8139too kmod-r8169 kmod-sis900 kmod-tg3 \
- kmod-via-rhine kmod-via-velocity
-endef
-
-define Profile/Generic/Description
- Generic Profile for x86 architecture
-endef
-$(eval $(call Profile,Generic))
diff --git a/target/linux/x86/geode/profiles/000-Generic.mk b/target/linux/x86/geode/profiles/000-Generic.mk
deleted file mode 100644
index be11b33e97..0000000000
--- a/target/linux/x86/geode/profiles/000-Generic.mk
+++ /dev/null
@@ -1,20 +0,0 @@
-#
-# Copyright (C) 2006-2019 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Generic
- NAME:=Generic x86/Geode
- PACKAGES:= \
- soloscli linux-atm br2684ctl ppp-mod-pppoa pppdump pppstats \
- hwclock flashrom tc kmod-pppoa kmod-8139cp kmod-mppe \
- kmod-usb-ohci-pci kmod-hwmon-lm90 \
- kmod-via-rhine
-endef
-
-define Profile/Generic/Description
- Generic Profile for all Geode boards.
-endef
-$(eval $(call Profile,Generic))
diff --git a/target/linux/x86/geode/profiles/100-Geos.mk b/target/linux/x86/geode/profiles/100-Geos.mk
deleted file mode 100644
index f51e892cbf..0000000000
--- a/target/linux/x86/geode/profiles/100-Geos.mk
+++ /dev/null
@@ -1,19 +0,0 @@
-#
-# Copyright (C) 2006-2019 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Geos
- NAME:=Geos
- PACKAGES:= \
- soloscli linux-atm br2684ctl ppp-mod-pppoa pppdump pppstats \
- hwclock flashrom tc kmod-pppoa kmod-8139cp kmod-mppe \
- kmod-usb-ohci-pci kmod-hwmon-lm90
-endef
-
-define Profile/Geos/Description
- Traverse Technologies Geos ADSL router
-endef
-$(eval $(call Profile,Geos))
diff --git a/target/linux/x86/legacy/profiles/000-Generic.mk b/target/linux/x86/legacy/profiles/000-Generic.mk
deleted file mode 100644
index 566a66c1be..0000000000
--- a/target/linux/x86/legacy/profiles/000-Generic.mk
+++ /dev/null
@@ -1,18 +0,0 @@
-#
-# Copyright (C) 2006-2019 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Generic
- NAME:=Generic x86/legacy
- PACKAGES:=kmod-3c59x kmod-e100 kmod-e1000 kmod-natsemi kmod-ne2k-pci \
- kmod-pcnet32 kmod-8139too kmod-r8169 kmod-sis900 kmod-tg3 \
- kmod-via-rhine kmod-via-velocity
-endef
-
-define Profile/Generic/Description
- Generic Profile for x86 legacy architecutre
-endef
-$(eval $(call Profile,Generic))