aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2020-04-25 12:47:43 +0200
committerPetr Štetiar <ynezz@true.cz>2020-04-26 12:53:27 +0200
commit97d86426e2ec4e6a875f82aa6e0ffdb802fbde22 (patch)
tree81a6628434952bf25cfa63111cb723049d10f08b /target/linux/x86
parentb359a6b948a6e25682ef5b6e82d2df8448b37c94 (diff)
downloadupstream-97d86426e2ec4e6a875f82aa6e0ffdb802fbde22.tar.gz
upstream-97d86426e2ec4e6a875f82aa6e0ffdb802fbde22.tar.bz2
upstream-97d86426e2ec4e6a875f82aa6e0ffdb802fbde22.zip
x86: fix unusable squashfs images by adding missing padding
It was reported, that after image generation rework x86-64-generic-squashfs-rootfs.img image won't boot on XenServer x86_64 anymore: F2FS-fs (xvda): Magic Mismatch, valid(0xf2f52010) - read(0x84289960) F2FS-fs (xvda): Can't find valid F2FS filesystem in 1th superblock F2FS-fs (xvda): Magic Mismatch, valid(0xf2f52010) - read(0x4e8ee223) F2FS-fs (xvda): Can't find valid F2FS filesystem in 2th superblock List of all partitions: ca00 4207 xvda driver: vbd No filesystem could mount root, tried: ext3 ext2 ext4 squashfs iso9660 f2fs Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(202,0) So lets fix this by adding back padding which was introduced in commit a17d9482f5e2 ("x86: image: fix small disk space in squashfs overlay"). Ref: FS#3036 Fixes: 258f070d1a4f ("x86: fix missing squashfs and ext4 rootfs images") Fixes: cb007a7bf619 ("x86: switch image generation to new code") Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'target/linux/x86')
-rw-r--r--target/linux/x86/image/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/x86/image/Makefile b/target/linux/x86/image/Makefile
index 72a4d66ad7..174c272a51 100644
--- a/target/linux/x86/image/Makefile
+++ b/target/linux/x86/image/Makefile
@@ -111,8 +111,8 @@ define Device/Default
IMAGE/combined.img.gz := grub-config pc | combined | grub-install | gzip | append-metadata
IMAGE/combined.vdi := grub-config pc | combined | grub-install | qemu-image vdi
IMAGE/combined.vmdk := grub-config pc | combined | grub-install | qemu-image vmdk
- IMAGE/rootfs.img := append-rootfs
- IMAGE/rootfs.img.gz := append-rootfs | gzip
+ IMAGE/rootfs.img := append-rootfs | pad-to $(ROOTFS_PARTSIZE)
+ IMAGE/rootfs.img.gz := append-rootfs | pad-to $(ROOTFS_PARTSIZE) | gzip
ARTIFACT/image-efi.iso := grub-config iso | iso efi
IMAGE/combined-efi.img := grub-config efi | combined efi | grub-install efi | append-metadata
IMAGE/combined-efi.img.gz := grub-config efi | combined efi | grub-install efi | gzip | append-metadata