aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86
diff options
context:
space:
mode:
authorChuanhong Guo <gch981213@gmail.com>2021-04-18 18:05:08 +0800
committerChuanhong Guo <gch981213@gmail.com>2021-04-18 18:05:08 +0800
commit37958f0d115fe8e9f87091b0242efc2e9ac9c8bf (patch)
tree922b18216d1f19db02fe2fa970ccfffe7d704bcd /target/linux/x86
parent4f8da19572cf1adc480dca42251a4cded0cb3c7c (diff)
downloadupstream-37958f0d115fe8e9f87091b0242efc2e9ac9c8bf.tar.gz
upstream-37958f0d115fe8e9f87091b0242efc2e9ac9c8bf.tar.bz2
upstream-37958f0d115fe8e9f87091b0242efc2e9ac9c8bf.zip
x86: amd-xgbe: add missing dependencies on 5.10
fix the following build error when building with test kernel: Package kmod-amd-xgbe is missing dependencies for the following libraries: mdio_devres.ko Signed-off-by: Chuanhong Guo <gch981213@gmail.com>
Diffstat (limited to 'target/linux/x86')
-rw-r--r--target/linux/x86/modules.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/x86/modules.mk b/target/linux/x86/modules.mk
index 41295d2d1f..d31e4535df 100644
--- a/target/linux/x86/modules.mk
+++ b/target/linux/x86/modules.mk
@@ -22,7 +22,7 @@ $(eval $(call KernelPackage,amazon-ena))
define KernelPackage/amd-xgbe
SUBMENU:=$(NETWORK_DEVICES_MENU)
TITLE:=AMD Ethernet on SoC support
- DEPENDS:=@PCI_SUPPORT @TARGET_x86_64 +kmod-lib-crc32c +kmod-ptp +kmod-libphy
+ DEPENDS:=@PCI_SUPPORT @TARGET_x86_64 +kmod-lib-crc32c +kmod-ptp +kmod-libphy +LINUX_5_10:kmod-mdio-devres
KCONFIG:=CONFIG_AMD_XGBE
FILES:=$(LINUX_DIR)/drivers/net/ethernet/amd/xgbe/amd-xgbe.ko
AUTOLOAD:=$(call AutoLoad,35,amd-xgbe)