aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86
diff options
context:
space:
mode:
authorFlorian Eckert <fe@dev.tdt.de>2022-08-03 16:22:12 +0200
committerChristian Lamparter <chunkeey@gmail.com>2022-09-24 23:53:53 +0200
commit355c02d963c20d5f32d5759a1cffa149d1a36162 (patch)
treedefdafd20f215ae33597683574b5c9ef055f2915 /target/linux/x86
parent0de6a3339f1aadc1de2c9371435e3de239a00645 (diff)
downloadupstream-355c02d963c20d5f32d5759a1cffa149d1a36162.tar.gz
upstream-355c02d963c20d5f32d5759a1cffa149d1a36162.tar.bz2
upstream-355c02d963c20d5f32d5759a1cffa149d1a36162.zip
linux/x86: add missing CONFIG_WATCHDOG_CORE to *-wdt
The packages also need a dependency to watchdog core. This commit adds the needed WATCHDOG_CORE dependency. https://github.com/torvalds/linux/blob/master/drivers/watchdog/Kconfig Signed-off-by: Florian Eckert <fe@dev.tdt.de>
Diffstat (limited to 'target/linux/x86')
-rw-r--r--target/linux/x86/modules.mk14
1 files changed, 10 insertions, 4 deletions
diff --git a/target/linux/x86/modules.mk b/target/linux/x86/modules.mk
index 28cb276f7e..3173cf9e84 100644
--- a/target/linux/x86/modules.mk
+++ b/target/linux/x86/modules.mk
@@ -39,7 +39,9 @@ define KernelPackage/f71808e-wdt
SUBMENU:=$(OTHER_MENU)
TITLE:=Fintek F718xx/F818xx Watchdog Timer
DEPENDS:=@TARGET_x86
- KCONFIG:=CONFIG_F71808E_WDT
+ KCONFIG:=\
+ CONFIG_F71808E_WDT \
+ CONFIG_WATCHDOG_CORE=y
FILES:=$(LINUX_DIR)/drivers/watchdog/f71808e_wdt.ko
AUTOLOAD:=$(call AutoProbe,f71808e-wdt,1)
endef
@@ -123,8 +125,10 @@ define KernelPackage/itco-wdt
SUBMENU:=$(OTHER_MENU)
TITLE:=Intel iTCO Watchdog Timer
DEPENDS:=@TARGET_x86
- KCONFIG:=CONFIG_ITCO_WDT \
- CONFIG_ITCO_VENDOR_SUPPORT=y
+ KCONFIG:=\
+ CONFIG_ITCO_WDT \
+ CONFIG_ITCO_VENDOR_SUPPORT=y \
+ CONFIG_WATCHDOG_CORE=y
FILES:=$(LINUX_DIR)/drivers/watchdog/iTCO_wdt.ko \
$(LINUX_DIR)/drivers/watchdog/iTCO_vendor_support.ko
AUTOLOAD:=$(call AutoLoad,50,iTCO_vendor_support iTCO_wdt,1)
@@ -178,7 +182,9 @@ define KernelPackage/w83627hf-wdt
SUBMENU:=$(OTHER_MENU)
TITLE:=Winbond 83627HF Watchdog Timer
DEPENDS:=@TARGET_x86
- KCONFIG:=CONFIG_W83627HF_WDT
+ KCONFIG:=\
+ CONFIG_W83627HF_WDT \
+ ONFIG_WATCHDOG_CORE=y
FILES:=$(LINUX_DIR)/drivers/watchdog/w83627hf_wdt.ko
AUTOLOAD:=$(call AutoLoad,50,w83627hf-wdt,1)
endef