aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2021-01-23 22:09:27 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2021-01-23 23:42:47 +0100
commit29167cbca3653de05a8b915bc21327dac7d05174 (patch)
tree94e82974721d6ceec923bbabfba46fa2b6643d6b /target/linux/x86
parent4571ef48d8226dda152f921bd12eb254bea001bd (diff)
downloadupstream-29167cbca3653de05a8b915bc21327dac7d05174.tar.gz
upstream-29167cbca3653de05a8b915bc21327dac7d05174.tar.bz2
upstream-29167cbca3653de05a8b915bc21327dac7d05174.zip
x86: fix upgrade by emptying SUPPORTED_DEVICES
x86 uses append-metadata, but only for signing and not for the metadata itself. Since recently SUPPORTED_DEVICES was assigned with a global value and is not empty anymore, append-metadata will now actually put metadata into x86 images. This breaks sysupgrade on x86. To fix it for the moment, let's just empty SUPPORTED_DEVICES for this target again. In the long term, one should either not add metadata to the images if it is not desired, and/or remove the unintended fwtool check. Fixes: f52081bcf938 ("treewide: provide global default for SUPPORTED_DEVICES") Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/x86')
-rw-r--r--target/linux/x86/image/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/target/linux/x86/image/Makefile b/target/linux/x86/image/Makefile
index 85c850c128..81aab20666 100644
--- a/target/linux/x86/image/Makefile
+++ b/target/linux/x86/image/Makefile
@@ -144,6 +144,7 @@ define Device/Default
endif
IMAGES := $$(IMAGES-y)
ARTIFACTS := $$(ARTIFACTS-y)
+ SUPPORTED_DEVICES :=
endef
include $(SUBTARGET).mk