aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86/patches-5.4/011-tune_lzma_options.patch
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2020-02-23 14:55:25 +0100
committerKoen Vandeputte <koen.vandeputte@ncentric.com>2020-02-28 17:50:46 +0100
commit5af55933e063c01f64bba78f352e95b978a47cc1 (patch)
tree8239d5dd1cf11e3eb0acc7ac1e68ace141a9c35c /target/linux/x86/patches-5.4/011-tune_lzma_options.patch
parent4e0c54bc5bc8381e031af5147b66b4dadeecc626 (diff)
downloadupstream-5af55933e063c01f64bba78f352e95b978a47cc1.tar.gz
upstream-5af55933e063c01f64bba78f352e95b978a47cc1.tar.bz2
upstream-5af55933e063c01f64bba78f352e95b978a47cc1.zip
x86: copy kernel patches from 4.19 to 5.4
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'target/linux/x86/patches-5.4/011-tune_lzma_options.patch')
-rw-r--r--target/linux/x86/patches-5.4/011-tune_lzma_options.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/x86/patches-5.4/011-tune_lzma_options.patch b/target/linux/x86/patches-5.4/011-tune_lzma_options.patch
new file mode 100644
index 0000000000..09d3c6c7ce
--- /dev/null
+++ b/target/linux/x86/patches-5.4/011-tune_lzma_options.patch
@@ -0,0 +1,22 @@
+--- a/scripts/Makefile.lib
++++ b/scripts/Makefile.lib
+@@ -325,7 +325,7 @@ cmd_bzip2 = (cat $(filter-out FORCE,$^)
+
+ quiet_cmd_lzma = LZMA $@
+ cmd_lzma = (cat $(filter-out FORCE,$^) | \
+- lzma e -d20 -lc1 -lp2 -pb2 -eos -si -so && $(call size_append, $(filter-out FORCE,$^))) > $@ || \
++ lzma e -lc8 -eos -si -so && $(call size_append, $(filter-out FORCE,$^))) > $@ || \
+ (rm -f $@ ; false)
+
+ quiet_cmd_lzo = LZO $@
+--- a/arch/x86/include/asm/boot.h
++++ b/arch/x86/include/asm/boot.h
+@@ -24,7 +24,7 @@
+ # error "Invalid value for CONFIG_PHYSICAL_ALIGN"
+ #endif
+
+-#ifdef CONFIG_KERNEL_BZIP2
++#if defined(CONFIG_KERNEL_BZIP2) || defined(CONFIG_KERNEL_LZMA)
+ # define BOOT_HEAP_SIZE 0x400000
+ #else /* !CONFIG_KERNEL_BZIP2 */
+ # define BOOT_HEAP_SIZE 0x10000