aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86/net5501
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2010-04-11 12:36:55 +0000
committerFlorian Fainelli <florian@openwrt.org>2010-04-11 12:36:55 +0000
commit15e8d2e0b7e28d0a1ae8ffc848ca5b35e82362de (patch)
tree2ce61df795f2025bddb44de7715816298bdab534 /target/linux/x86/net5501
parent62b96185c30d8a9fcd38173fc991b3e9145bca92 (diff)
downloadupstream-15e8d2e0b7e28d0a1ae8ffc848ca5b35e82362de.tar.gz
upstream-15e8d2e0b7e28d0a1ae8ffc848ca5b35e82362de.tar.bz2
upstream-15e8d2e0b7e28d0a1ae8ffc848ca5b35e82362de.zip
add net5501 support
This patch brings up the net5501 platform. Note that the x86/ target included support for all x86/ class processors. That's not technically correct. This should be constrained only to the "generic" subtarget. Every x86-class target that isn't generic should be able to select only the optimizations/capabilities applicable to that architectural variant. It's also assumed that all x86 processors have keyboard & mouse ports, ISA, DMI, ACPI... the embedded ones typically don't. Again, moving that to the generic subtarget. Fortunately, this was a fairly benign tweak. The net5501 board includes the following logic: Geode/LX processor CS5535 super-I/O chip PC87360 sensor chip Via Rhine Ethernet controllers Via Sata controllers USB, LEDS, I2C Signed-off-by: Philip Prindeville <philipp_subx@redfish-solutions.com> SVN-Revision: 20794
Diffstat (limited to 'target/linux/x86/net5501')
-rw-r--r--target/linux/x86/net5501/config-default25
-rw-r--r--target/linux/x86/net5501/target.mk15
2 files changed, 40 insertions, 0 deletions
diff --git a/target/linux/x86/net5501/config-default b/target/linux/x86/net5501/config-default
new file mode 100644
index 0000000000..20f10a29c6
--- /dev/null
+++ b/target/linux/x86/net5501/config-default
@@ -0,0 +1,25 @@
+# CONFIG_ACPI is not set
+# CONFIG_DMI is not set
+CONFIG_CPU_SUP_AMD=y
+CONFIG_GEODE_MFGPT_TIMER=y
+# CONFIG_GEODE_WDT is not set
+CONFIG_HAVE_PERF_EVENTS=y
+CONFIG_HWMON=y
+# CONFIG_HWMON_DEBUG_CHIP is not set
+# CONFIG_ISA is not set
+# CONFIG_INPUT is not set
+# CONFIG_KEYBOARD_ATKBD is not set
+# CONFIG_M486 is not set
+CONFIG_MGEODE_LX=y
+# CONFIG_MOUSE_PS2 is not set
+# CONFIG_PCSPKR_PLATFORM is not set
+CONFIG_PROCESSOR_SELECT=y
+# CONFIG_SCx200 is not set
+# CONFIG_SERIO_I8042 is not set
+# CONFIG_SERIO_LIBPS2 is not set
+CONFIG_X86_DEBUGCTLMSR=y
+# CONFIG_X86_DS is not set
+CONFIG_X86_L1_CACHE_SHIFT=5
+CONFIG_X86_TSC=y
+CONFIG_X86_USE_3DNOW=y
+CONFIG_X86_USE_PPRO_CHECKSUM=y
diff --git a/target/linux/x86/net5501/target.mk b/target/linux/x86/net5501/target.mk
new file mode 100644
index 0000000000..be4cefe680
--- /dev/null
+++ b/target/linux/x86/net5501/target.mk
@@ -0,0 +1,15 @@
+BOARDNAME:=Soekris net5501
+DEFAULT_PACKAGES += kmod-ata-via-sata kmod-crypto-hw-geode \
+ kmod-cs5535-gpio kmod-nsc-gpio kmod-pc8736x-gpio \
+ kmod-geodewdt kmod-hwmon-core kmod-hwmon-pc87360 \
+ kmod-via-rhine \
+ kmod-i2c-core kmod-i2c-gpio \
+ kmod-i2c-algo-bit kmod-i2c-algo-pca kmod-i2c-algo-pcf \
+ kmod-usb-core kmod-usb2 kmod-usb-hid kmod-usb-uhci
+CFLAGS += -march=k6-2 -fno-align-functions -fno-align-loops -fno-align-jumps \
+ -fno-align-labels
+
+define Target/Description
+ Build firmware images for Soekris net5501 board
+endef
+