aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86/modules.mk
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2012-10-15 18:54:34 +0000
committerFlorian Fainelli <florian@openwrt.org>2012-10-15 18:54:34 +0000
commit86148ac69bbfb69d10b5118b6583fb0c94ede629 (patch)
tree74e95a2a02effb3010d559674ce6040bcd54f1be /target/linux/x86/modules.mk
parent75d227f4f8687bf9c76229cd5ecb8e72e328d05e (diff)
downloadupstream-86148ac69bbfb69d10b5118b6583fb0c94ede629.tar.gz
upstream-86148ac69bbfb69d10b5118b6583fb0c94ede629.tar.bz2
upstream-86148ac69bbfb69d10b5118b6583fb0c94ede629.zip
[x86] merge the RDC R-321x target as a subtarget of x86
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33779 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/x86/modules.mk')
-rw-r--r--target/linux/x86/modules.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/target/linux/x86/modules.mk b/target/linux/x86/modules.mk
index 70a64ffdb4..f0d436c1e9 100644
--- a/target/linux/x86/modules.mk
+++ b/target/linux/x86/modules.mk
@@ -312,3 +312,19 @@ define KernelPackage/leds-net48xx/description
endef
$(eval $(call KernelPackage,leds-net48xx))
+
+define KernelPackage/rdc321x-wdt
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=RDC321x watchdog
+ DEPENDS:=@TARGET_x86_rdc
+ KCONFIG:=CONFIG_RDC321X_WDT
+ FILES:=$(LINUX_DIR)/drivers/$(WATCHDOG_DIR)/rdc321x_wdt.ko
+ AUTOLOAD:=$(call AutoLoad,50,rdc321x_wdt)
+endef
+
+define KernelPackage/rdc321x-wdt/description
+ RDC-321x watchdog driver
+endef
+
+$(eval $(call KernelPackage,rdc321x-wdt))
+