aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86/image
diff options
context:
space:
mode:
author李国 <uxgood.org@gmail.com>2020-03-26 13:51:32 +0800
committerPetr Štetiar <ynezz@true.cz>2020-03-31 16:20:47 +0200
commitd9228514ccecfb9d1500e3a82470f66f2ea41a39 (patch)
treed9ce7dfed0b554dc6053895d169a1a66692985af /target/linux/x86/image
parent1963bbaa8f035c0a3c71233a049a7a4d7cd32711 (diff)
downloadupstream-d9228514ccecfb9d1500e3a82470f66f2ea41a39.tar.gz
upstream-d9228514ccecfb9d1500e3a82470f66f2ea41a39.tar.bz2
upstream-d9228514ccecfb9d1500e3a82470f66f2ea41a39.zip
grub2: make some change to add efi platform support
1.generate boot image at Package/install section 2.move boot image to $(STAGING_DIR_IMAGE)/grub2/ 3.add efi variant to support efi platform Signed-off-by: 李国 <uxgood.org@gmail.com>
Diffstat (limited to 'target/linux/x86/image')
-rw-r--r--target/linux/x86/image/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/target/linux/x86/image/Makefile b/target/linux/x86/image/Makefile
index c0c5c8323a..4915f639fa 100644
--- a/target/linux/x86/image/Makefile
+++ b/target/linux/x86/image/Makefile
@@ -70,9 +70,8 @@ endef
define Build/grub-install
rm -fR $@.grub2
$(INSTALL_DIR) $@.grub2
- $(CP) $(STAGING_DIR_HOST)/lib/grub/i386-pc/*.img \
- $(STAGING_DIR_HOST)/lib/grub/grub2-$(GRUB2_VARIANT)/core.img \
- $@.grub2/
+ $(CP) $(STAGING_DIR_IMAGE)/grub2/boot.img $@.grub2/
+ $(CP) $(STAGING_DIR_IMAGE)/grub2/$(GRUB2_VARIANT)-core.img $@.grub2/core.img
echo '(hd0) $@' > $@.grub2/device.map
$(STAGING_DIR_HOST)/bin/grub-bios-setup \
-m "$@.grub2/device.map" \
@@ -84,8 +83,8 @@ endef
define Build/iso
$(CP) $(KDIR)/$(KERNEL_NAME) $@.boot/boot/vmlinuz
cat \
- $(STAGING_DIR_HOST)/lib/grub/i386-pc/cdboot.img \
- $(STAGING_DIR_HOST)/lib/grub/grub2-iso/eltorito.img \
+ $(STAGING_DIR_IMAGE)/grub2/cdboot.img \
+ $(STAGING_DIR_IMAGE)/grub2/eltorito.img \
> $@.boot/boot/grub/eltorito.img
-$(CP) $(STAGING_DIR_ROOT)/boot/. $@.boot/boot/
mkisofs -R -b boot/grub/eltorito.img -no-emul-boot -boot-info-table \