aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86/image
diff options
context:
space:
mode:
authorAlberto Bursi <bobafetthotmail@gmail.com>2021-02-06 20:25:32 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2021-03-01 00:34:23 +0100
commit788ec9a7cfc843c8e46451331521cdc7d81866bd (patch)
tree9de7edb098e4da10478b617edbfd5c66b3205f44 /target/linux/x86/image
parent0c0c9c734d216b69f404a80eab4f9989a4fc9d42 (diff)
downloadupstream-788ec9a7cfc843c8e46451331521cdc7d81866bd.tar.gz
upstream-788ec9a7cfc843c8e46451331521cdc7d81866bd.tar.bz2
upstream-788ec9a7cfc843c8e46451331521cdc7d81866bd.zip
x86: add support for AWS T3 instances
Amazon AWS T3 cloud instances require kernel support for the Elastic Fabric Adapter to access storage and for Elastic Network Adapter to use network interfaces. Since the Fabric Adapter is needed to access root filesystem, enable in x86_64 kernel. Elastic Network Adapter goes in a module, and add this module to default list in x86_64. The module is set to AutoLoad because AutoProbe does not seem to load it. Signed-off-by: Alberto Bursi <bobafetthotmail@gmail.com>
Diffstat (limited to 'target/linux/x86/image')
-rw-r--r--target/linux/x86/image/64.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/x86/image/64.mk b/target/linux/x86/image/64.mk
index 745b307585..edbf503052 100644
--- a/target/linux/x86/image/64.mk
+++ b/target/linux/x86/image/64.mk
@@ -1,7 +1,7 @@
define Device/generic
DEVICE_TITLE := Generic x86/64
- DEVICE_PACKAGES += kmod-bnx2 kmod-e1000e kmod-e1000 kmod-forcedeth kmod-igb \
- kmod-ixgbe kmod-r8169
+ DEVICE_PACKAGES += kmod-amazon-ena kmod-bnx2 kmod-e1000e kmod-e1000 \
+ kmod-forcedeth kmod-igb kmod-ixgbe kmod-r8169
GRUB2_VARIANT := generic
endef
TARGET_DEVICES += generic