aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86/image/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-02-12 19:04:12 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-02-12 19:04:12 +0000
commite0fc8fb6aa2ae71c146e70e5b803ea8638e36e01 (patch)
tree0b2463119d0ec28244618a975778d38183b00ad8 /target/linux/x86/image/Makefile
parente48f324dc0df2d84e6663e95a8234888ebf4bbb1 (diff)
downloadupstream-e0fc8fb6aa2ae71c146e70e5b803ea8638e36e01.tar.gz
upstream-e0fc8fb6aa2ae71c146e70e5b803ea8638e36e01.tar.bz2
upstream-e0fc8fb6aa2ae71c146e70e5b803ea8638e36e01.zip
make console port editable through menuconfig, gzip ext2 images, add suitable defaults for Xen
SVN-Revision: 19612
Diffstat (limited to 'target/linux/x86/image/Makefile')
-rw-r--r--target/linux/x86/image/Makefile13
1 files changed, 10 insertions, 3 deletions
diff --git a/target/linux/x86/image/Makefile b/target/linux/x86/image/Makefile
index 51490fa791..13712cf0ea 100644
--- a/target/linux/x86/image/Makefile
+++ b/target/linux/x86/image/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -20,6 +20,9 @@ ROOTPART=$(strip $(subst ",, $(CONFIG_OLPC_BOOTSCRIPT_ROOTPART)))
endif
#"))")) # fix vim's broken syntax highlighting
+CONSOLE=$(strip $(subst ",, $(CONFIG_X86_GRUB_CONSOLE)))
+
+
ifeq ($(CONFIG_X86_GRUB_IMAGES),y)
ifneq ($(HOST_OS),Darwin)
define Image/cmdline/squashfs
@@ -47,6 +50,7 @@ ifneq ($(HOST_OS),Darwin)
$(CP) $(KDIR)/bzImage $(KDIR)/root.grub/boot/vmlinuz
sed \
-e 's#@CMDLINE@#$(strip $(call Image/cmdline/$(1))) $(BOOTOPTS)#g' \
+ -e 's#@CONSOLE@#$(CONSOLE)#g' \
-e 's#@BAUDRATE@#$(CONFIG_X86_GRUB_BAUDRATE)#g' \
./menu.lst > $(KDIR)/root.grub/boot/grub/menu.lst
PADDING="$(CONFIG_X86_GRUB_IMAGES_PAD)" PATH="$(TARGET_PATH)" ./gen_image_x86.sh $(BIN_DIR)/openwrt-$(BOARD)-$(1).image $(CONFIG_X86_GRUB_KERNELPART) $(KDIR)/root.grub $(CONFIG_TARGET_ROOTFS_FSPART) $(KDIR)/root.$(1)
@@ -153,13 +157,16 @@ endef
define Image/Build
$(call Image/Build/$(1))
$(call Image/Build/bootscript,$(1))
-ifneq ($(1),iso)
+ ifneq ($(1),iso)
$(call Image/Build/grub,$(1))
$(call Image/Build/vdi,$(1))
$(call Image/Build/vmdk,$(1))
-endif
+ endif
$(CP) $(KDIR)/root.$(1) $(BIN_DIR)/openwrt-$(BOARD)-$(1).fs
$(CP) $(KDIR)/bzImage $(BIN_DIR)/openwrt-$(BOARD)-vmlinuz
+ ifeq ($(1),ext2)
+ gzip -f9 $(BIN_DIR)/openwrt-$(BOARD)-$(1).image
+ endif
endef
$(eval $(call BuildImage))