aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86/image/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-07-20 08:18:50 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-07-20 08:18:50 +0000
commitc718d0b10cea2d539b3f7db0beccf298caf0659e (patch)
tree54b032a4b1d2dce3248fb3125577a3cc3332316b /target/linux/x86/image/Makefile
parent286780b44a6280d156f9b95b1582856aa6e77f4e (diff)
downloadupstream-c718d0b10cea2d539b3f7db0beccf298caf0659e.tar.gz
upstream-c718d0b10cea2d539b3f7db0beccf298caf0659e.tar.bz2
upstream-c718d0b10cea2d539b3f7db0beccf298caf0659e.zip
x86: remove the arbitrary limitation of vmware/virtualbox images to ext4, select TARGET_IMAGES_PAD instead
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 41763
Diffstat (limited to 'target/linux/x86/image/Makefile')
-rw-r--r--target/linux/x86/image/Makefile26
1 files changed, 10 insertions, 16 deletions
diff --git a/target/linux/x86/image/Makefile b/target/linux/x86/image/Makefile
index 03aa350da2..59837180f1 100644
--- a/target/linux/x86/image/Makefile
+++ b/target/linux/x86/image/Makefile
@@ -160,27 +160,21 @@ endef
ifneq ($(CONFIG_VDI_IMAGES),)
define Image/Build/vdi
- # left here because the image builder doesnt need these
- ifeq ($(1),ext4)
- rm $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).vdi || true
- qemu-img convert -f raw -O vdi \
- $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).img \
- $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).vdi
- # XXX: VBoxManage insists on setting perms to 0600
- chmod 0644 $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).vdi
- endif
+ rm $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).vdi || true
+ qemu-img convert -f raw -O vdi \
+ $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).img \
+ $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).vdi
+ # XXX: VBoxManage insists on setting perms to 0600
+ chmod 0644 $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).vdi
endef
endif
ifneq ($(CONFIG_VMDK_IMAGES),)
define Image/Build/vmdk
- # left here because the image builder doesnt need these
- ifeq ($(1),ext4)
- rm $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).vmdk || true
- qemu-img convert -f raw -O vmdk \
- $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).img \
- $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).vmdk
- endif
+ rm $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).vmdk || true
+ qemu-img convert -f raw -O vmdk \
+ $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).img \
+ $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).vmdk
endef
endif