aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86/image/Makefile
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2010-11-22 12:12:39 +0000
committerImre Kaloz <kaloz@openwrt.org>2010-11-22 12:12:39 +0000
commitc1725149e15b97d88bf8518543be15269bbec6af (patch)
tree546b7bb3d3fec36635a8979ef611f64be31743d8 /target/linux/x86/image/Makefile
parentb0f15545ca8656df1248462a37f17cc789d611de (diff)
downloadupstream-c1725149e15b97d88bf8518543be15269bbec6af.tar.gz
upstream-c1725149e15b97d88bf8518543be15269bbec6af.tar.bz2
upstream-c1725149e15b97d88bf8518543be15269bbec6af.zip
switch from ext2 to ext4 (w/o) journaling
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@24084 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/x86/image/Makefile')
-rw-r--r--target/linux/x86/image/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/target/linux/x86/image/Makefile b/target/linux/x86/image/Makefile
index b5297bbff8..57d7b0b46d 100644
--- a/target/linux/x86/image/Makefile
+++ b/target/linux/x86/image/Makefile
@@ -35,8 +35,8 @@ ifneq ($(CONFIG_X86_GRUB_IMAGES),)
BOOTOPTS:=$(call qstrip,$(CONFIG_X86_GRUB_BOOTOPTS))
- define Image/cmdline/ext2
- root=$(ROOTPART) rootfstype=ext2 rootwait
+ define Image/cmdline/ext4
+ root=$(ROOTPART) rootfstype=ext4 rootwait
endef
define Image/cmdline/jffs2-64k
@@ -88,8 +88,8 @@ ROOTDELAY=10
ifneq ($(CONFIG_OLPC_BOOTSCRIPT_IMAGES),)
- define Image/cmdline/ext2
- root=$(ROOTPART) rootfstype=ext2 rootwait
+ define Image/cmdline/ext4
+ root=$(ROOTPART) rootfstype=ext4 rootwait
endef
define Image/cmdline/jffs2-64k
@@ -141,7 +141,7 @@ endef
ifneq ($(CONFIG_X86_VDI_IMAGES),)
define Image/Build/vdi
# left here because the image builder doesnt need these
- ifeq ($(1),ext2)
+ ifeq ($(1),ext4)
rm $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).vdi || true
qemu-img convert -f raw -O vdi \
$(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).img \
@@ -155,7 +155,7 @@ endif
ifneq ($(CONFIG_X86_VMDK_IMAGES),)
define Image/Build/vmdk
# left here because the image builder doesnt need these
- ifeq ($(1),ext2)
+ ifeq ($(1),ext4)
rm $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).vmdk || true
qemu-img convert -f raw -O vmdk \
$(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).img \
@@ -184,7 +184,7 @@ define Image/Build
endif
$(CP) $(KDIR)/root.$(1) $(BIN_DIR)/$(IMG_PREFIX)-rootfs-$(1).img
$(CP) $(KDIR)/bzImage $(BIN_DIR)/$(IMG_PREFIX)-vmlinuz
- ifeq ($(1),ext2)
+ ifeq ($(1),ext4)
gzip -f9 $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).img
gzip -f9 $(BIN_DIR)/$(IMG_PREFIX)-rootfs-$(1).img
endif