aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86/image/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-01-19 01:14:45 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-01-19 01:14:45 +0000
commit2fc3fe1d095eae9e68a5e802b47b0a73f43685a8 (patch)
tree2c4f52e0d24e46eef22acfd5c288924b5a700506 /target/linux/x86/image/Makefile
parent095f7f2da3322e791def4e304d36ffb0215e0051 (diff)
downloadupstream-2fc3fe1d095eae9e68a5e802b47b0a73f43685a8.tar.gz
upstream-2fc3fe1d095eae9e68a5e802b47b0a73f43685a8.tar.bz2
upstream-2fc3fe1d095eae9e68a5e802b47b0a73f43685a8.zip
Make the grub timeout configurable on x86 targets
Signed-off-by: Justus Winter <4winter@informatik.uni-hamburg.de> SVN-Revision: 29786
Diffstat (limited to 'target/linux/x86/image/Makefile')
-rw-r--r--target/linux/x86/image/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/target/linux/x86/image/Makefile b/target/linux/x86/image/Makefile
index c070a10319..185da1096c 100644
--- a/target/linux/x86/image/Makefile
+++ b/target/linux/x86/image/Makefile
@@ -31,6 +31,8 @@ endif
ROOTPART:=$(call qstrip,$(CONFIG_TARGET_ROOTFS_PARTNAME))
+GRUB_TIMEOUT:=$(call qstrip,$(CONFIG_X86_GRUB_TIMEOUT))
+
ifneq ($(CONFIG_X86_GRUB_IMAGES),)
BOOTOPTS:=$(call qstrip,$(CONFIG_X86_GRUB_BOOTOPTS))
@@ -64,6 +66,7 @@ ifneq ($(CONFIG_X86_GRUB_IMAGES),)
-e 's#@SERIAL_CONFIG@#$(strip $(GRUB_SERIAL_CONFIG))#g' \
-e 's#@TERMINAL_CONFIG@#$(strip $(GRUB_TERMINAL_CONFIG))#g' \
-e 's#@CMDLINE@#$(strip $(call Image/cmdline/$(1)) $(BOOTOPTS) $(GRUB_CONSOLE_CMDLINE))#g' \
+ -e 's#@TIMEOUT@#$(GRUB_TIMEOUT)#g' \
./menu.lst > $(KDIR)/root.grub/boot/grub/menu.lst
PADDING="$(CONFIG_TARGET_IMAGES_PAD)" PATH="$(TARGET_PATH)" ./gen_image_x86.sh \
$(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).img \