aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86-2.6/image/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-01-07 16:13:39 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-01-07 16:13:39 +0000
commite320d3be58651c8844c89fa3b81ed7a9d74f836d (patch)
tree84a41082ae72e4b7cf8267920eaf583cb1323a9a /target/linux/x86-2.6/image/Makefile
parent6b830552a2ba36b6ed774a65c589863ae30c1aef (diff)
downloadupstream-e320d3be58651c8844c89fa3b81ed7a9d74f836d.tar.gz
upstream-e320d3be58651c8844c89fa3b81ed7a9d74f836d.tar.bz2
upstream-e320d3be58651c8844c89fa3b81ed7a9d74f836d.zip
fix grub bootopts (#1145)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6019 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/x86-2.6/image/Makefile')
-rw-r--r--target/linux/x86-2.6/image/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/x86-2.6/image/Makefile b/target/linux/x86-2.6/image/Makefile
index 7e76523d91..e1425676dd 100644
--- a/target/linux/x86-2.6/image/Makefile
+++ b/target/linux/x86-2.6/image/Makefile
@@ -30,7 +30,7 @@ ifeq ($(CONFIG_X86_GRUB_IMAGES),y)
endef
define Image/cmdline/ext2
- root=$(ROOTPART) rootfstype=ext2 $(CONFIG_X86_GRUB_BOOTOPTS)
+ root=$(ROOTPART) rootfstype=ext2
endef
define Image/Build/grub
@@ -42,7 +42,7 @@ ifeq ($(CONFIG_X86_GRUB_IMAGES),y)
$(KDIR)/root.grub/boot/grub/
$(CP) $(LINUX_DIR)/arch/i386/boot/bzImage $(KDIR)/root.grub/boot/vmlinuz
sed \
- -e 's#@CMDLINE@#$(strip $(call Image/cmdline/$(1)))#g' \
+ -e 's#@CMDLINE@#$(strip $(call Image/cmdline/$(1))) $(CONFIG_X86_GRUB_BOOTOPTS)#g' \
-e 's#@BAUDRATE@#$(CONFIG_X86_GRUB_BAUDRATE)#g' \
./grub/menu.lst > $(KDIR)/root.grub/boot/grub/menu.lst
PATH="$(STAGING_DIR)/usr/sbin:$(STAGING_DIR)/bin:$(PATH)" ./gen_image.sh $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).image $(CONFIG_X86_GRUB_KERNELPART) $(KDIR)/root.grub $(CONFIG_TARGET_ROOTFS_FSPART) $(KDIR)/root.$(1)