aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86-2.6/image/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-03-05 00:38:37 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-03-05 00:38:37 +0000
commitbc025545712ccefe9e21845b6a70b198468fc6c4 (patch)
tree26085a8746f215037aea37268189356ed29c8bda /target/linux/x86-2.6/image/Makefile
parent708a9364d53030b04f89cf10ab0729b859c0c617 (diff)
downloadupstream-bc025545712ccefe9e21845b6a70b198468fc6c4.tar.gz
upstream-bc025545712ccefe9e21845b6a70b198468fc6c4.tar.bz2
upstream-bc025545712ccefe9e21845b6a70b198468fc6c4.zip
add missing init=/etc/preinit cmdline parameter
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6523 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/x86-2.6/image/Makefile')
-rw-r--r--target/linux/x86-2.6/image/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/x86-2.6/image/Makefile b/target/linux/x86-2.6/image/Makefile
index 9c26d6851c..c5a2163256 100644
--- a/target/linux/x86-2.6/image/Makefile
+++ b/target/linux/x86-2.6/image/Makefile
@@ -27,11 +27,11 @@ ifeq ($(CONFIG_X86_GRUB_IMAGES),y)
endef
define Image/cmdline/jffs2-64k
- block2mtd.block2mtd=$(ROOTPART),65536,rootfs root=/dev/mtdblock0 rootfstype=jffs2
+ block2mtd.block2mtd=$(ROOTPART),65536,rootfs root=/dev/mtdblock0 rootfstype=jffs2 init=/etc/preinit
endef
define Image/cmdline/jffs2-128k
- block2mtd.block2mtd=$(ROOTPART),131072,rootfs root=/dev/mtdblock0 rootfstype=jffs2
+ block2mtd.block2mtd=$(ROOTPART),131072,rootfs root=/dev/mtdblock0 rootfstype=jffs2 init=/etc/preinit
endef
define Image/cmdline/ext2