aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86-2.6/image/Makefile
diff options
context:
space:
mode:
authorMike Baker <mbm@openwrt.org>2006-11-28 20:14:41 +0000
committerMike Baker <mbm@openwrt.org>2006-11-28 20:14:41 +0000
commit3ba3ea17ba671bf4bd7632fffa3d37728112acd4 (patch)
treea07315dd45c6ac0f7d0e6a337cf58f7d7b09d07f /target/linux/x86-2.6/image/Makefile
parent1a9e1bf731c009cdde791100b96fc4f6404d83ea (diff)
downloadupstream-3ba3ea17ba671bf4bd7632fffa3d37728112acd4.tar.gz
upstream-3ba3ea17ba671bf4bd7632fffa3d37728112acd4.tar.bz2
upstream-3ba3ea17ba671bf4bd7632fffa3d37728112acd4.zip
move target/image/platform to target/linux/platform/image
platform directories are now self contained git-svn-id: svn://svn.openwrt.org/openwrt/trunk@5669 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/x86-2.6/image/Makefile')
-rw-r--r--target/linux/x86-2.6/image/Makefile62
1 files changed, 62 insertions, 0 deletions
diff --git a/target/linux/x86-2.6/image/Makefile b/target/linux/x86-2.6/image/Makefile
new file mode 100644
index 0000000000..7aa03b2d27
--- /dev/null
+++ b/target/linux/x86-2.6/image/Makefile
@@ -0,0 +1,62 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
+export PATH=$(TARGET_PATH):/sbin
+ROOTPART=$(strip $(subst ",, $(CONFIG_X86_GRUB_ROOTPART)))
+#")) # fix vim's broken syntax highlighting
+
+
+ifeq ($(CONFIG_X86_GRUB_IMAGES),y)
+ define Build/Compile
+ $(MAKE) -C grub compile
+ endef
+
+ define Build/Clean
+ $(MAKE) -C grub clean
+ endef
+
+ define Image/cmdline/jffs2-64k
+ block2mtd.block2mtd=$(ROOTPART),65536 root=/dev/mtdblock0 rootfstype=jffs2
+ endef
+
+ define Image/cmdline/jffs2-128k
+ block2mtd.block2mtd=$(ROOTPART),131072 root=/dev/mtdblock0 rootfstype=jffs2
+ endef
+
+ define Image/cmdline/ext2
+ root=$(ROOTPART) rootfstype=ext2 $(CONFIG_X86_GRUB_BOOTOPTS)
+ endef
+
+ define Image/Build/grub
+ mkdir -p $(KDIR)/root.grub/boot/grub
+ $(CP) \
+ $(STAGING_DIR)/usr/lib/grub/i386-pc/stage1 \
+ $(STAGING_DIR)/usr/lib/grub/i386-pc/stage2 \
+ $(STAGING_DIR)/usr/lib/grub/i386-pc/e2fs_stage1_5 \
+ $(KDIR)/root.grub/boot/grub/
+ $(CP) $(LINUX_DIR)/arch/i386/boot/bzImage $(KDIR)/root.grub/boot/vmlinuz
+ sed \
+ -e 's#@CMDLINE@#$(strip $(call Image/cmdline/$(1)))#g' \
+ -e 's#@BAUDRATE@#$(CONFIG_X86_GRUB_BAUDRATE)#g' \
+ ./grub/menu.lst > $(KDIR)/root.grub/boot/grub/menu.lst
+ PATH="$(STAGING_DIR)/usr/sbin:$(STAGING_DIR)/bin:$(PATH)" ./gen_image.sh $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).image $(CONFIG_X86_GRUB_KERNELPART) $(KDIR)/root.grub $(CONFIG_TARGET_ROOTFS_FSPART) $(KDIR)/root.$(1)
+ endef
+endif
+
+define Image/Build
+ $(call Image/Build/grub,$(1))
+ cp $(KDIR)/root.$(1) $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).fs
+ cp $(LINUX_DIR)/arch/i386/boot/bzImage $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinuz
+endef
+
+$(eval $(call BuildImage))
+
+$(eval $(call RequireCommand,fdisk, \
+ Please install fdisk \
+))