aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/versatile/Makefile
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2010-11-08 07:31:31 +0000
committerFlorian Fainelli <florian@openwrt.org>2010-11-08 07:31:31 +0000
commit6a61d2d905837736644acef39ce2f688764e5707 (patch)
tree93d7d1ee438e612bb2146a3f608222435899ed63 /target/linux/versatile/Makefile
parentb6e9f1dfe08740a77da7def31ca05e8ca548bed6 (diff)
downloadupstream-6a61d2d905837736644acef39ce2f688764e5707.tar.gz
upstream-6a61d2d905837736644acef39ce2f688764e5707.tar.bz2
upstream-6a61d2d905837736644acef39ce2f688764e5707.zip
add target to be used with qemu
SVN-Revision: 23920
Diffstat (limited to 'target/linux/versatile/Makefile')
-rw-r--r--target/linux/versatile/Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/target/linux/versatile/Makefile b/target/linux/versatile/Makefile
new file mode 100644
index 0000000000..6ec2d35add
--- /dev/null
+++ b/target/linux/versatile/Makefile
@@ -0,0 +1,21 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=arm
+BOARD:=versatile
+BOARDNAME:=ARM Versatile board (qemu)
+FEATURES:=squashfs jffs2
+CFLAGS:=-Os -pipe -march=armv5te -mtune=arm926ej-s -funit-at-a-time
+
+LINUX_VERSION:=2.6.36
+
+include $(INCLUDE_DIR)/target.mk
+
+KERNELNAME:="zImage"
+
+$(eval $(call BuildTarget))