aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/uml
diff options
context:
space:
mode:
authorFlorian Fainelli <f.fainelli@gmail.com>2017-10-22 14:56:12 -0700
committerFlorian Fainelli <f.fainelli@gmail.com>2017-10-24 15:10:23 -0700
commitfd75e4d264d305347647a29ae2dab56c9f3967c9 (patch)
treeb1ede17d36f59acc4f3513aaa0f6cf096c7d8b06 /target/linux/uml
parent5e425ad42445750b3b995a93b3083f41ae381a3f (diff)
downloadupstream-fd75e4d264d305347647a29ae2dab56c9f3967c9.tar.gz
upstream-fd75e4d264d305347647a29ae2dab56c9f3967c9.tar.bz2
upstream-fd75e4d264d305347647a29ae2dab56c9f3967c9.zip
uml: Add 4.9 kernel patches
102-pseudo-random-mac.patch required an update to the new style asynchronous crypto Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
Diffstat (limited to 'target/linux/uml')
-rw-r--r--target/linux/uml/patches-4.9/000-um-Avoid-longjmp-setjmp-symbol-clashes-with-libpthre.patch130
-rw-r--r--target/linux/uml/patches-4.9/001-um-Allow-building-and-running-on-older-hosts.patch99
-rw-r--r--target/linux/uml/patches-4.9/002-um-Correctly-check-for-PTRACE_GETRESET-SETREGSET.patch29
-rw-r--r--target/linux/uml/patches-4.9/003-um-Fix-check-for-_xstate-for-older-hosts.patch46
-rw-r--r--target/linux/uml/patches-4.9/101-mconsole-exec.patch211
-rw-r--r--target/linux/uml/patches-4.9/102-pseudo-random-mac.patch131
6 files changed, 646 insertions, 0 deletions
diff --git a/target/linux/uml/patches-4.9/000-um-Avoid-longjmp-setjmp-symbol-clashes-with-libpthre.patch b/target/linux/uml/patches-4.9/000-um-Avoid-longjmp-setjmp-symbol-clashes-with-libpthre.patch
new file mode 100644
index 0000000000..02149eea7a
--- /dev/null
+++ b/target/linux/uml/patches-4.9/000-um-Avoid-longjmp-setjmp-symbol-clashes-with-libpthre.patch
@@ -0,0 +1,130 @@
+From f44f1e7da7c8e3f4575d5d61c4df978496903fcc Mon Sep 17 00:00:00 2001
+From: Florian Fainelli <f.fainelli@gmail.com>
+Date: Tue, 23 May 2017 17:32:31 -0700
+Subject: [PATCH] um: Avoid longjmp/setjmp symbol clashes with libpthread.a
+
+[ Upstream commit f44f1e7da7c8e3f4575d5d61c4df978496903fcc ]
+
+Building a statically linked UML kernel on a Centos 6.9 host resulted in
+the following linking failure (GCC 4.4, glibc-2.12):
+
+/usr/lib/gcc/x86_64-redhat-linux/4.4.7/../../../../lib64/libpthread.a(libpthread.o):
+In function `siglongjmp':
+(.text+0x8490): multiple definition of `longjmp'
+arch/x86/um/built-in.o:/local/users/fainelli/openwrt/trunk/build_dir/target-x86_64_musl/linux-uml/linux-4.4.69/arch/x86/um/setjmp_64.S:44:
+first defined here
+/usr/lib/gcc/x86_64-redhat-linux/4.4.7/../../../../lib64/libpthread.a(libpthread.o):
+In function `sem_open':
+(.text+0x77cd): warning: the use of `mktemp' is dangerous, better use
+`mkstemp'
+collect2: ld returned 1 exit status
+make[4]: *** [vmlinux] Error 1
+
+Adopt a solution similar to the one done for vmap where we define
+longjmp/setjmp to be kernel_longjmp/setjmp. In the process, make sure we
+do rename the functions in arch/x86/um/setjmp_*.S accordingly.
+
+Fixes: a7df4716d195 ("um: link with -lpthread")
+Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
+Signed-off-by: Richard Weinberger <richard@nod.at>
+---
+ arch/um/Makefile | 4 ++++
+ arch/x86/um/setjmp_32.S | 16 ++++++++--------
+ arch/x86/um/setjmp_64.S | 16 ++++++++--------
+ 3 files changed, 20 insertions(+), 16 deletions(-)
+
+--- a/arch/um/Makefile
++++ b/arch/um/Makefile
+@@ -59,10 +59,14 @@ KBUILD_CPPFLAGS += -I$(srctree)/$(HOST_D
+ # Same things for in6addr_loopback and mktime - found in libc. For these two we
+ # only get link-time error, luckily.
+ #
++# -Dlongjmp=kernel_longjmp prevents anything from referencing the libpthread.a
++# embedded copy of longjmp, same thing for setjmp.
++#
+ # These apply to USER_CFLAGS to.
+
+ KBUILD_CFLAGS += $(CFLAGS) $(CFLAGS-y) -D__arch_um__ \
+ $(ARCH_INCLUDE) $(MODE_INCLUDE) -Dvmap=kernel_vmap \
++ -Dlongjmp=kernel_longjmp -Dsetjmp=kernel_setjmp \
+ -Din6addr_loopback=kernel_in6addr_loopback \
+ -Din6addr_any=kernel_in6addr_any -Dstrrchr=kernel_strrchr
+
+--- a/arch/x86/um/setjmp_32.S
++++ b/arch/x86/um/setjmp_32.S
+@@ -16,9 +16,9 @@
+
+ .text
+ .align 4
+- .globl setjmp
+- .type setjmp, @function
+-setjmp:
++ .globl kernel_setjmp
++ .type kernel_setjmp, @function
++kernel_setjmp:
+ #ifdef _REGPARM
+ movl %eax,%edx
+ #else
+@@ -35,13 +35,13 @@ setjmp:
+ movl %ecx,20(%edx) # Return address
+ ret
+
+- .size setjmp,.-setjmp
++ .size kernel_setjmp,.-kernel_setjmp
+
+ .text
+ .align 4
+- .globl longjmp
+- .type longjmp, @function
+-longjmp:
++ .globl kernel_longjmp
++ .type kernel_longjmp, @function
++kernel_longjmp:
+ #ifdef _REGPARM
+ xchgl %eax,%edx
+ #else
+@@ -55,4 +55,4 @@ longjmp:
+ movl 16(%edx),%edi
+ jmp *20(%edx)
+
+- .size longjmp,.-longjmp
++ .size kernel_longjmp,.-kernel_longjmp
+--- a/arch/x86/um/setjmp_64.S
++++ b/arch/x86/um/setjmp_64.S
+@@ -18,9 +18,9 @@
+
+ .text
+ .align 4
+- .globl setjmp
+- .type setjmp, @function
+-setjmp:
++ .globl kernel_setjmp
++ .type kernel_setjmp, @function
++kernel_setjmp:
+ pop %rsi # Return address, and adjust the stack
+ xorl %eax,%eax # Return value
+ movq %rbx,(%rdi)
+@@ -34,13 +34,13 @@ setjmp:
+ movq %rsi,56(%rdi) # Return address
+ ret
+
+- .size setjmp,.-setjmp
++ .size kernel_setjmp,.-kernel_setjmp
+
+ .text
+ .align 4
+- .globl longjmp
+- .type longjmp, @function
+-longjmp:
++ .globl kernel_longjmp
++ .type kernel_longjmp, @function
++kernel_longjmp:
+ movl %esi,%eax # Return value (int)
+ movq (%rdi),%rbx
+ movq 8(%rdi),%rsp
+@@ -51,4 +51,4 @@ longjmp:
+ movq 48(%rdi),%r15
+ jmp *56(%rdi)
+
+- .size longjmp,.-longjmp
++ .size kernel_longjmp,.-kernel_longjmp
diff --git a/target/linux/uml/patches-4.9/001-um-Allow-building-and-running-on-older-hosts.patch b/target/linux/uml/patches-4.9/001-um-Allow-building-and-running-on-older-hosts.patch
new file mode 100644
index 0000000000..9de557bfd5
--- /dev/null
+++ b/target/linux/uml/patches-4.9/001-um-Allow-building-and-running-on-older-hosts.patch
@@ -0,0 +1,99 @@
+From 0a987645672ebde7844a9c0732a5a25f3d4bb6c6 Mon Sep 17 00:00:00 2001
+From: Florian Fainelli <f.fainelli@gmail.com>
+Date: Thu, 25 May 2017 11:36:26 -0700
+Subject: [PATCH] um: Allow building and running on older hosts
+
+[ Upstream commit 0a987645672ebde7844a9c0732a5a25f3d4bb6c6 ]
+
+Commit a78ff1112263 ("um: add extended processor state save/restore
+support") and b6024b21fec8 ("um: extend fpstate to _xstate to support
+YMM registers") forced the use of the x86 FP _xstate and
+PTRACE_GETREGSET/SETREGSET. On older hosts, we would neither be able to
+build UML nor run it anymore with these two commits applied because we
+don't have definitions for struct _xstate nor these two ptrace requests.
+
+We can determine at build time which fp context structure to check
+against, just like we can keep using the old i387 fp save/restore if
+PTRACE_GETRESET/SETREGSET are not defined.
+
+Fixes: a78ff1112263 ("um: add extended processor state save/restore support")
+Fixes: b6024b21fec8 ("um: extend fpstate to _xstate to support YMM registers")
+Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
+Signed-off-by: Richard Weinberger <richard@nod.at>
+---
+ arch/x86/um/os-Linux/registers.c | 12 ++++++++----
+ arch/x86/um/user-offsets.c | 4 ++++
+ 2 files changed, 12 insertions(+), 4 deletions(-)
+
+--- a/arch/x86/um/os-Linux/registers.c
++++ b/arch/x86/um/os-Linux/registers.c
+@@ -26,6 +26,7 @@ int save_i387_registers(int pid, unsigne
+
+ int save_fp_registers(int pid, unsigned long *fp_regs)
+ {
++#ifdef PTRACE_GETREGSET
+ struct iovec iov;
+
+ if (have_xstate_support) {
+@@ -34,9 +35,9 @@ int save_fp_registers(int pid, unsigned
+ if (ptrace(PTRACE_GETREGSET, pid, NT_X86_XSTATE, &iov) < 0)
+ return -errno;
+ return 0;
+- } else {
++ } else
++#endif
+ return save_i387_registers(pid, fp_regs);
+- }
+ }
+
+ int restore_i387_registers(int pid, unsigned long *fp_regs)
+@@ -48,6 +49,7 @@ int restore_i387_registers(int pid, unsi
+
+ int restore_fp_registers(int pid, unsigned long *fp_regs)
+ {
++#ifdef PTRACE_SETREGSET
+ struct iovec iov;
+
+ if (have_xstate_support) {
+@@ -56,9 +58,9 @@ int restore_fp_registers(int pid, unsign
+ if (ptrace(PTRACE_SETREGSET, pid, NT_X86_XSTATE, &iov) < 0)
+ return -errno;
+ return 0;
+- } else {
++ } else
++#endif
+ return restore_i387_registers(pid, fp_regs);
+- }
+ }
+
+ #ifdef __i386__
+@@ -122,6 +124,7 @@ int put_fp_registers(int pid, unsigned l
+
+ void arch_init_registers(int pid)
+ {
++#ifdef PTRACE_GETREGSET
+ struct _xstate fp_regs;
+ struct iovec iov;
+
+@@ -129,6 +132,7 @@ void arch_init_registers(int pid)
+ iov.iov_len = sizeof(struct _xstate);
+ if (ptrace(PTRACE_GETREGSET, pid, NT_X86_XSTATE, &iov) == 0)
+ have_xstate_support = 1;
++#endif
+ }
+ #endif
+
+--- a/arch/x86/um/user-offsets.c
++++ b/arch/x86/um/user-offsets.c
+@@ -50,7 +50,11 @@ void foo(void)
+ DEFINE(HOST_GS, GS);
+ DEFINE(HOST_ORIG_AX, ORIG_EAX);
+ #else
++#if defined(PTRACE_GETREGSET) && defined(PTRACE_SETREGSET)
+ DEFINE(HOST_FP_SIZE, sizeof(struct _xstate) / sizeof(unsigned long));
++#else
++ DEFINE(HOST_FP_SIZE, sizeof(struct _fpstate) / sizeof(unsigned long));
++#endif
+ DEFINE_LONGS(HOST_BX, RBX);
+ DEFINE_LONGS(HOST_CX, RCX);
+ DEFINE_LONGS(HOST_DI, RDI);
diff --git a/target/linux/uml/patches-4.9/002-um-Correctly-check-for-PTRACE_GETRESET-SETREGSET.patch b/target/linux/uml/patches-4.9/002-um-Correctly-check-for-PTRACE_GETRESET-SETREGSET.patch
new file mode 100644
index 0000000000..79beb823c2
--- /dev/null
+++ b/target/linux/uml/patches-4.9/002-um-Correctly-check-for-PTRACE_GETRESET-SETREGSET.patch
@@ -0,0 +1,29 @@
+From 61e8d462457f202bf0c6393133425ad387825e22 Mon Sep 17 00:00:00 2001
+From: Richard Weinberger <richard@nod.at>
+Date: Thu, 6 Jul 2017 09:35:27 +0200
+Subject: [PATCH] um: Correctly check for PTRACE_GETRESET/SETREGSET
+
+[ Upstream commit 61e8d462457f202bf0c6393133425ad387825e22 ]
+
+When checking for PTRACE_GETRESET/SETREGSET, make sure that
+the correct header file is included. We need linux/ptrace.h
+which contains all ptrace UAPI related defines.
+Otherwise #if defined(PTRACE_GETRESET) is always false.
+
+Cc: Florian Fainelli <f.fainelli@gmail.com>
+Signed-off-by: Richard Weinberger <richard@nod.at>
+---
+ arch/x86/um/user-offsets.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+--- a/arch/x86/um/user-offsets.c
++++ b/arch/x86/um/user-offsets.c
+@@ -5,7 +5,7 @@
+ #include <sys/mman.h>
+ #include <sys/user.h>
+ #define __FRAME_OFFSETS
+-#include <asm/ptrace.h>
++#include <linux/ptrace.h>
+ #include <asm/types.h>
+
+ #ifdef __i386__
diff --git a/target/linux/uml/patches-4.9/003-um-Fix-check-for-_xstate-for-older-hosts.patch b/target/linux/uml/patches-4.9/003-um-Fix-check-for-_xstate-for-older-hosts.patch
new file mode 100644
index 0000000000..b31ca4191b
--- /dev/null
+++ b/target/linux/uml/patches-4.9/003-um-Fix-check-for-_xstate-for-older-hosts.patch
@@ -0,0 +1,46 @@
+From 2fb44600fe784449404c6639de26af8361999ec7 Mon Sep 17 00:00:00 2001
+From: Florian Fainelli <f.fainelli@gmail.com>
+Date: Tue, 18 Jul 2017 16:43:47 -0700
+Subject: [PATCH] um: Fix check for _xstate for older hosts
+
+Commit 0a987645672e ("um: Allow building and running on older
+hosts") attempted to check for PTRACE_{GET,SET}REGSET under the premise
+that these ptrace(2) parameters were directly linked with the presence
+of the _xstate structure.
+
+After Richard's commit 61e8d462457f ("um: Correctly check for
+PTRACE_GETRESET/SETREGSET") which properly included linux/ptrace.h
+instead of asm/ptrace.h, we could get into the original build failure
+that I reported:
+
+arch/x86/um/user-offsets.c: In function 'foo':
+arch/x86/um/user-offsets.c:54: error: invalid application of 'sizeof' to
+incomplete type 'struct _xstate'
+
+On this particular host, we do have PTRACE_GETREGSET and
+PTRACE_SETREGSET defined in linux/ptrace.h, but not the structure
+_xstate that should be pulled from the following include chain: signal.h
+-> bits/sigcontext.h.
+
+Correctly fix this by checking for FP_XSTATE_MAGIC1 which is the correct
+way to see if struct _xstate is available or not on the host.
+
+Fixes: 61e8d462457f ("um: Correctly check for PTRACE_GETRESET/SETREGSET")
+Fixes: 0a987645672e ("um: Allow building and running on older hosts")
+Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
+Signed-off-by: Richard Weinberger <richard@nod.at>
+---
+ arch/x86/um/user-offsets.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+--- a/arch/x86/um/user-offsets.c
++++ b/arch/x86/um/user-offsets.c
+@@ -50,7 +50,7 @@ void foo(void)
+ DEFINE(HOST_GS, GS);
+ DEFINE(HOST_ORIG_AX, ORIG_EAX);
+ #else
+-#if defined(PTRACE_GETREGSET) && defined(PTRACE_SETREGSET)
++#ifdef FP_XSTATE_MAGIC1
+ DEFINE(HOST_FP_SIZE, sizeof(struct _xstate) / sizeof(unsigned long));
+ #else
+ DEFINE(HOST_FP_SIZE, sizeof(struct _fpstate) / sizeof(unsigned long));
diff --git a/target/linux/uml/patches-4.9/101-mconsole-exec.patch b/target/linux/uml/patches-4.9/101-mconsole-exec.patch
new file mode 100644
index 0000000000..6682338f39
--- /dev/null
+++ b/target/linux/uml/patches-4.9/101-mconsole-exec.patch
@@ -0,0 +1,211 @@
+#
+# Minimalist mconsole exec patch
+#
+# 3.10 version (with bit more synchronous behavior) by fingon at iki dot fi
+# Adaptation to kernel 3.3.8 made by David Fernández (david at dit.upm.es) for
+# Starting point: mconsole-exec-2.6.30.patch for kernel 2.6.30
+# Author of original patch: Paolo Giarrusso, aka Blaisorblade
+# (http://www.user-mode-linux.org/~blaisorblade)
+#
+# Known misfeatures:
+#
+# - If output is too long, blocks (and breaks horribly)
+# (this misfeature from 3.10 patches, when minimalizing the patch;
+# workaround: redirect to a shared filesystem if long output is expected)
+#
+# - Nothing useful is done with stdin
+#
+--- a/arch/um/drivers/mconsole.h
++++ b/arch/um/drivers/mconsole.h
+@@ -85,6 +85,7 @@ extern void mconsole_cad(struct mc_reque
+ extern void mconsole_stop(struct mc_request *req);
+ extern void mconsole_go(struct mc_request *req);
+ extern void mconsole_log(struct mc_request *req);
++extern void mconsole_exec(struct mc_request *req);
+ extern void mconsole_proc(struct mc_request *req);
+ extern void mconsole_stack(struct mc_request *req);
+
+--- a/arch/um/drivers/mconsole_kern.c
++++ b/arch/um/drivers/mconsole_kern.c
+@@ -4,6 +4,7 @@
+ * Licensed under the GPL
+ */
+
++#include "linux/kmod.h"
+ #include <linux/console.h>
+ #include <linux/ctype.h>
+ #include <linux/string.h>
+@@ -24,6 +25,7 @@
+ #include <linux/fs.h>
+ #include <linux/mount.h>
+ #include <linux/file.h>
++#include <linux/completion.h>
+ #include <asm/uaccess.h>
+ #include <asm/switch_to.h>
+
+@@ -121,6 +123,59 @@ void mconsole_log(struct mc_request *req
+ mconsole_reply(req, "", 0, 0);
+ }
+
++void mconsole_exec(struct mc_request *req)
++{
++ struct subprocess_info *sub_info;
++ int res, len;
++ struct file *out;
++ char buf[MCONSOLE_MAX_DATA];
++
++ char *envp[] = {
++ "HOME=/", "TERM=linux",
++ "PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin",
++ NULL
++ };
++ char *argv[] = {
++ "/bin/sh", "-c",
++ req->request.data + strlen("exec "),
++ NULL
++ };
++
++ sub_info = call_usermodehelper_setup("/bin/sh", argv, envp, GFP_ATOMIC, NULL, NULL, NULL);
++ if (sub_info == NULL) {
++ mconsole_reply(req, "call_usermodehelper_setup failed", 1, 0);
++ return;
++ }
++ res = call_usermodehelper_stdoutpipe(sub_info, &out);
++ if (res < 0) {
++ kfree(sub_info);
++ mconsole_reply(req, "call_usermodehelper_stdoutpipe failed", 1, 0);
++ return;
++ }
++
++ res = call_usermodehelper_exec(sub_info, UMH_WAIT_PROC);
++ if (res < 0) {
++ kfree(sub_info);
++ mconsole_reply(req, "call_usermodehelper_exec failed", 1, 0);
++ return;
++ }
++
++ for (;;) {
++ len = out->f_op->read(out, buf, sizeof(buf), &out->f_pos);
++ if (len < 0) {
++ mconsole_reply(req, "reading output failed", 1, 0);
++ break;
++ }
++ if (len == 0)
++ break;
++ mconsole_reply_len(req, buf, len, 0, 1);
++ }
++ fput(out);
++
++ mconsole_reply_len(req, NULL, 0, 0, 0);
++}
++
++
+ void mconsole_proc(struct mc_request *req)
+ {
+ struct vfsmount *mnt = task_active_pid_ns(current)->proc_mnt;
+@@ -187,6 +242,7 @@ void mconsole_proc(struct mc_request *re
+ stop - pause the UML; it will do nothing until it receives a 'go' \n\
+ go - continue the UML after a 'stop' \n\
+ log <string> - make UML enter <string> into the kernel log\n\
++ exec <string> - pass <string> to /bin/sh -c synchronously\n\
+ proc <file> - returns the contents of the UML's /proc/<file>\n\
+ stack <pid> - returns the stack of the specified pid\n\
+ "
+--- a/arch/um/drivers/mconsole_user.c
++++ b/arch/um/drivers/mconsole_user.c
+@@ -30,6 +30,7 @@ static struct mconsole_command commands[
+ { "stop", mconsole_stop, MCONSOLE_PROC },
+ { "go", mconsole_go, MCONSOLE_INTR },
+ { "log", mconsole_log, MCONSOLE_INTR },
++ { "exec", mconsole_exec, MCONSOLE_PROC },
+ { "proc", mconsole_proc, MCONSOLE_PROC },
+ { "stack", mconsole_stack, MCONSOLE_INTR },
+ };
+--- a/arch/um/os-Linux/file.c
++++ b/arch/um/os-Linux/file.c
+@@ -554,6 +554,8 @@ int os_create_unix_socket(const char *fi
+
+ addr.sun_family = AF_UNIX;
+
++ if (len > sizeof(addr.sun_path))
++ len = sizeof(addr.sun_path);
+ snprintf(addr.sun_path, len, "%s", file);
+
+ err = bind(sock, (struct sockaddr *) &addr, sizeof(addr));
+--- a/include/linux/kmod.h
++++ b/include/linux/kmod.h
+@@ -62,6 +62,7 @@ struct subprocess_info {
+ int wait;
+ int retval;
+ int (*init)(struct subprocess_info *info, struct cred *new);
++ struct file *stdout;
+ void (*cleanup)(struct subprocess_info *info);
+ void *data;
+ };
+@@ -102,4 +103,6 @@ extern int usermodehelper_read_trylock(v
+ extern long usermodehelper_read_lock_wait(long timeout);
+ extern void usermodehelper_read_unlock(void);
+
++int call_usermodehelper_stdoutpipe(struct subprocess_info *sub_info, struct file **filp);
++
+ #endif /* __LINUX_KMOD_H__ */
+--- a/kernel/kmod.c
++++ b/kernel/kmod.c
+@@ -39,6 +39,7 @@
+ #include <linux/rwsem.h>
+ #include <linux/ptrace.h>
+ #include <linux/async.h>
++#include <linux/pipe_fs_i.h>
+ #include <asm/uaccess.h>
+
+ #include <trace/events/module.h>
+@@ -222,6 +223,28 @@ static int call_usermodehelper_exec_asyn
+ flush_signal_handlers(current, 1);
+ spin_unlock_irq(&current->sighand->siglock);
+
++ /* Install output when needed */
++ if (sub_info->stdout) {
++ struct files_struct *f = current->files;
++ struct fdtable *fdt;
++
++ sys_close(1);
++ sys_close(2);
++ get_file(sub_info->stdout);
++ fd_install(1, sub_info->stdout);
++ fd_install(2, sub_info->stdout);
++ spin_lock(&f->file_lock);
++ fdt = files_fdtable(f);
++ __set_bit(1, fdt->open_fds);
++ __clear_bit(1, fdt->close_on_exec);
++ __set_bit(2, fdt->open_fds);
++ __clear_bit(2, fdt->close_on_exec);
++ spin_unlock(&f->file_lock);
++
++ /* disallow core files */
++ current->signal->rlim[RLIMIT_CORE] = (struct rlimit){0, 0};
++ }
++
+ /*
+ * Our parent (unbound workqueue) runs with elevated scheduling
+ * priority. Avoid propagating that into the userspace child.
+@@ -540,6 +563,20 @@ struct subprocess_info *call_usermodehel
+ }
+ EXPORT_SYMBOL(call_usermodehelper_setup);
+
++int call_usermodehelper_stdoutpipe(struct subprocess_info *sub_info,
++ struct file **filp)
++{
++ struct file *f[2];
++
++ if (create_pipe_files(f, 0)<0)
++ return PTR_ERR(f);
++ sub_info->stdout = f[1];
++ *filp = f[0];
++ return 0;
++}
++EXPORT_SYMBOL(call_usermodehelper_stdoutpipe);
++
++
+ /**
+ * call_usermodehelper_exec - start a usermode application
+ * @sub_info: information about the subprocessa
diff --git a/target/linux/uml/patches-4.9/102-pseudo-random-mac.patch b/target/linux/uml/patches-4.9/102-pseudo-random-mac.patch
new file mode 100644
index 0000000000..a31d75ff38
--- /dev/null
+++ b/target/linux/uml/patches-4.9/102-pseudo-random-mac.patch
@@ -0,0 +1,131 @@
+===============================================================================
+
+This patch makes MAC addresses of network interfaces predictable. In
+particular, it adds a small routine that computes MAC addresses of based on
+a SHA1 hash of the virtual machine name and interface ID.
+
+TECHNICAL INFORMATION:
+
+Applies to vanilla kernel 3.9.4.
+
+===============================================================================
+--- a/arch/um/Kconfig.net
++++ b/arch/um/Kconfig.net
+@@ -21,6 +21,19 @@ config UML_NET
+ enable at least one of the following transport options to actually
+ make use of UML networking.
+
++config UML_NET_RANDOM_MAC
++ bool "Use random MAC addresses for network interfaces"
++ default n
++ depends on UML_NET
++ help
++ Virtual network devices inside a User-Mode Linux instance must be
++ assigned a MAC (Ethernet) address. If none is specified on the UML
++ command line, one must be automatically computed. If this option is
++ enabled, a randomly generated address is used. Otherwise, if this
++ option is disabled, the address is generated from a SHA1 hash of
++ the umid of the UML instance and the interface name. The latter choice
++ is useful to make MAC addresses predictable.
++
+ config UML_NET_ETHERTAP
+ bool "Ethertap transport"
+ depends on UML_NET
+--- a/arch/um/drivers/net_kern.c
++++ b/arch/um/drivers/net_kern.c
+@@ -25,6 +25,14 @@
+ #include <net_kern.h>
+ #include <net_user.h>
+
++#include <crypto/sha.h>
++#include <crypto/hash.h>
++#include <linux/string.h>
++#include <linux/crypto.h>
++#include <linux/err.h>
++#include <linux/scatterlist.h>
++#include "os.h"
++
+ #define DRIVER_NAME "uml-netdev"
+
+ static DEFINE_SPINLOCK(opened_lock);
+@@ -295,11 +303,53 @@ static void uml_net_user_timer_expire(un
+ #endif
+ }
+
++#ifndef CONFIG_UML_NET_RANDOM_MAC
++
++/* Compute a SHA1 hash of the UML instance's id and
++ * * an interface name. */
++static int compute_hash(const char *umid, const char *ifname, char *hash)
++{
++ struct ahash_request *desc;
++ struct crypto_ahash *tfm;
++ struct scatterlist sg;
++ char vmif[1024];
++ int ret;
++
++ strcpy (vmif, umid);
++ strcat (vmif, ifname);
++
++ tfm = crypto_alloc_ahash("sha1", 0, CRYPTO_ALG_ASYNC);
++ if (IS_ERR(tfm))
++ return -ENOMEM;
++
++ desc = ahash_request_alloc(tfm, GFP_KERNEL);
++ if (!desc) {
++ ret = -ENOMEM;
++ goto out;
++ }
++
++ crypto_ahash_clear_flags(tfm, ~0);
++
++ sg_init_table(&sg, 1);
++ sg_set_buf(&sg, vmif, strlen(vmif));
++
++ ahash_request_set_crypt(desc, &sg, hash, strlen(vmif));
++
++ ret = crypto_ahash_digest(desc);
++out:
++ crypto_free_ahash(tfm);
++
++ return ret;
++}
++
++#endif
++
+ static void setup_etheraddr(struct net_device *dev, char *str)
+ {
+ unsigned char *addr = dev->dev_addr;
+ char *end;
+ int i;
++ u8 hash[SHA1_DIGEST_SIZE];
+
+ if (str == NULL)
+ goto random;
+@@ -340,9 +390,26 @@ static void setup_etheraddr(struct net_d
+ return;
+
+ random:
++#ifdef CONFIG_UML_NET_RANDOM_MAC
+ printk(KERN_INFO
+ "Choosing a random ethernet address for device %s\n", dev->name);
+ eth_hw_addr_random(dev);
++#else
++ printk(KERN_INFO
++ "Computing a digest to use as ethernet address for device %s\n", dev->name);
++ if (compute_hash(get_umid(), dev->name, hash) < 0) {
++ printk(KERN_WARNING
++ "Could not compute digest to use as ethernet address for device %s. "
++ "Using random address instead.\n", dev->name);
++ random_ether_addr(addr);
++ }
++ else {
++ for (i=0; i < 6; i++)
++ addr[i] = (hash[i] + hash[i+6]) % 0x100;
++ }
++ addr [0] &= 0xfe; /* clear multicast bit */
++ addr [0] |= 0x02; /* set local assignment bit (IEEE802) */
++#endif
+ }
+
+ static DEFINE_SPINLOCK(devices_lock);