aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/uml/Makefile
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2021-10-19 17:41:08 -1000
committerPaul Spooren <mail@aparcar.org>2021-11-02 10:04:50 -1000
commit02c23d004c40cf8c24793ab8b4d2f4834356c33a (patch)
treefe2ed8e6a56803f3d45c1f40d5a10c42b07357d5 /target/linux/uml/Makefile
parent841738aa5571cf764587b779a8c377dcc5eb0855 (diff)
downloadupstream-02c23d004c40cf8c24793ab8b4d2f4834356c33a.tar.gz
upstream-02c23d004c40cf8c24793ab8b4d2f4834356c33a.tar.bz2
upstream-02c23d004c40cf8c24793ab8b4d2f4834356c33a.zip
uml: drop 32Bit host build support
This step drops support host build systems other than x86/64 to allow two Kernel configuration in parallel. With this commit the setup follow the config style of all other targets. Signed-off-by: Paul Spooren <mail@aparcar.org>
Diffstat (limited to 'target/linux/uml/Makefile')
-rw-r--r--target/linux/uml/Makefile15
1 files changed, 4 insertions, 11 deletions
diff --git a/target/linux/uml/Makefile b/target/linux/uml/Makefile
index ae8ea5d309..7c27dda036 100644
--- a/target/linux/uml/Makefile
+++ b/target/linux/uml/Makefile
@@ -1,20 +1,14 @@
# SPDX-License-Identifier: GPL-2.0-only
#
-# Copyright (C) 2006-2011 OpenWrt.org
+# Copyright (C) 2006-2021 OpenWrt.org
include $(TOPDIR)/rules.mk
# UML only makes sense on linux
ifeq ($(HOST_OS),Linux)
+ ifeq ($(HOST_ARCH),x86_64)
-ARCH:=$(shell uname -m | sed \
- -e 's/i[3-9]86/i386/' \
- -e 's/mipsel/mips/' \
- -e 's/mipseb/mips/' \
- -e 's/powerpc/ppc/' \
- -e 's/sh[234]/sh/' \
- -e 's/armeb/arm/' \
-)
+ARCH:=x86_64
BOARD:=uml
BOARDNAME:=User Mode Linux
FEATURES:=squashfs ext4 audio source-only
@@ -23,10 +17,9 @@ KERNEL_PATCHVER:=5.4
include $(INCLUDE_DIR)/target.mk
-LINUX_TARGET_CONFIG:=$(CURDIR)/config/$(ARCH)
-
DEFAULT_PACKAGES += wpad-basic-wolfssl kmod-mac80211-hwsim mkf2fs e2fsprogs
+ endif
endif
$(eval $(call BuildTarget))