aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/tegra
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2019-11-04 10:55:23 -1000
committerPetr Štetiar <ynezz@true.cz>2019-11-11 16:37:13 +0100
commite97113d5e18c31050bc06f7c6b7a5c663b5f31a4 (patch)
tree23ae74bd5c272deec16f973bd5208689550d42c7 /target/linux/tegra
parent98d1c7d83485ed2b024bf8ab5f8ff7e2a66ab85e (diff)
downloadupstream-e97113d5e18c31050bc06f7c6b7a5c663b5f31a4.tar.gz
upstream-e97113d5e18c31050bc06f7c6b7a5c663b5f31a4.tar.bz2
upstream-e97113d5e18c31050bc06f7c6b7a5c663b5f31a4.zip
x86,tegra,mvebu: image: use common reproducible IMG_PART_SIGNATURE
These targets are currently using more or less same SIGNATURE variable which provides unique partition ID/signature, so it makes sense to refactor it out into common IMG_PART_SIGNATURE variable which could be reused by all targets. This is another step in the direction of reproducible OpenWrt images. Signed-off-by: Paul Spooren <mail@aparcar.org> [split into separate commit, renamed to IMG_PART_SIGNATURE] Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'target/linux/tegra')
-rw-r--r--target/linux/tegra/image/Makefile6
1 files changed, 2 insertions, 4 deletions
diff --git a/target/linux/tegra/image/Makefile b/target/linux/tegra/image/Makefile
index 2ce8659995..10bada9c38 100644
--- a/target/linux/tegra/image/Makefile
+++ b/target/linux/tegra/image/Makefile
@@ -7,8 +7,6 @@
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
-SIGNATURE:=$(shell printf "%.8s" $(SOURCE_DATE_EPOCH))
-
define Build/tegra-sdcard
rm -fR $@.boot
mkdir -p $@.boot
@@ -17,7 +15,7 @@ define Build/tegra-sdcard
$(foreach dtb,$(DEVICE_DTS),$(CP) $(DTS_DIR)/$(dtb).dtb $@.boot), \
$(CP) $(DTS_DIR)/*.dtb $@.boot)
sed \
- -e 's#@ROOT@#$(SIGNATURE)#g' \
+ -e 's#@ROOT@#$(IMG_PART_SIGNATURE)#g' \
-e 's#@KERNEL@#$(KERNEL_NAME)#g' \
$(BOOT_SCRIPT) > $@-boot.scr
mkimage -A arm -O linux -T script -C none -a 0 -e 0 \
@@ -25,7 +23,7 @@ define Build/tegra-sdcard
-d $@-boot.scr \
$@.boot/boot.scr
- SIGNATURE="$(SIGNATURE)" \
+ SIGNATURE="$(IMG_PART_SIGNATURE)" \
$(SCRIPT_DIR)/gen_image_generic.sh \
$@ \
$(CONFIG_TARGET_KERNEL_PARTSIZE) $@.boot \