aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/tegra
diff options
context:
space:
mode:
authorTomasz Maciej Nowak <tmn505@gmail.com>2020-11-25 17:10:04 +0100
committerPetr Štetiar <ynezz@true.cz>2020-12-22 18:59:10 +0100
commitbbd665f38d6b48e56bb5ef38ee0eeceb02a8e129 (patch)
tree5a225e9a81b733becfcf7d222799b4d9547c7e91 /target/linux/tegra
parentfa7705103714a2abf8b3771712b002a6d46076c8 (diff)
downloadupstream-bbd665f38d6b48e56bb5ef38ee0eeceb02a8e129.tar.gz
upstream-bbd665f38d6b48e56bb5ef38ee0eeceb02a8e129.tar.bz2
upstream-bbd665f38d6b48e56bb5ef38ee0eeceb02a8e129.zip
tegra: image: make bootscript standalone
Don't hard-code the PTUUID, use U-Boot commands to determine it, as some partitioning tools could rewrite PTUUID when modifying partitions. Signed-off-by: Tomasz Maciej Nowak <tmn505@gmail.com>
Diffstat (limited to 'target/linux/tegra')
-rw-r--r--target/linux/tegra/image/Makefile5
-rw-r--r--target/linux/tegra/image/generic-bootscript4
2 files changed, 4 insertions, 5 deletions
diff --git a/target/linux/tegra/image/Makefile b/target/linux/tegra/image/Makefile
index aa0083f9ae..fbff1cf6e8 100644
--- a/target/linux/tegra/image/Makefile
+++ b/target/linux/tegra/image/Makefile
@@ -14,10 +14,7 @@ define Build/tegra-sdcard
$(if $(DEVICE_DTS),\
$(foreach dtb,$(DEVICE_DTS),$(CP) $(DTS_DIR)/$(dtb).dtb $@.boot), \
$(CP) $(DTS_DIR)/*.dtb $@.boot)
- sed \
- -e 's#@ROOT@#$(IMG_PART_SIGNATURE)#g' \
- -e 's#@KERNEL@#$(KERNEL_NAME)#g' \
- $(BOOT_SCRIPT) > $@-boot.scr
+ sed -e 's#@KERNEL@#$(KERNEL_NAME)#g' $(BOOT_SCRIPT) > $@-boot.scr
mkimage -A arm -O linux -T script -C none -a 0 -e 0 \
-n '$(DEVICE_TITLE) OpenWrt bootscript' \
-d $@-boot.scr \
diff --git a/target/linux/tegra/image/generic-bootscript b/target/linux/tegra/image/generic-bootscript
index 7e86afdf5f..0908025d5d 100644
--- a/target/linux/tegra/image/generic-bootscript
+++ b/target/linux/tegra/image/generic-bootscript
@@ -1,4 +1,6 @@
-setenv bootargs "root=PARTUUID=@ROOT@-02 rw rootwait console=ttyS0,115200 console=tty0"
+part uuid ${devtype} ${devnum}:2 ptuuid
+
+setenv bootargs "root=PARTUUID=${ptuuid} rw rootwait console=ttyS0,115200 console=tty0"
load ${devtype} ${devnum}:${bootpart} ${kernel_addr_r} /@KERNEL@
load ${devtype} ${devnum}:${bootpart} ${fdt_addr_r} /${soc}-${board}.dtb