aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/sunxi
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2020-07-27 12:30:41 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-08-20 14:19:39 +0200
commita14f5bb4bd263c21e103f13279d0c2ff03e48fe5 (patch)
tree18eecef0be1356f014d81b0427471ae18c8839c2 /target/linux/sunxi
parentcc75344044e5c16cd4994d824db5779a5ac057c2 (diff)
downloadupstream-a14f5bb4bd263c21e103f13279d0c2ff03e48fe5.tar.gz
upstream-a14f5bb4bd263c21e103f13279d0c2ff03e48fe5.tar.bz2
upstream-a14f5bb4bd263c21e103f13279d0c2ff03e48fe5.zip
treewide: use wpad-basic-wolfssl as default
In order to support SAE/WPA3-Personal in default images. Replace almost all occurencies of wpad-basic and wpad-mini with wpad-basic-wolfssl for consistency. Keep out ar71xx from the list as it won't be in the next release and would only make backports harder. Build-tested (build-bot settings): ath79: generic, ramips: mt7620/mt76x8/rt305x, lantiq: xrx200/xway, sunxi: a53 Signed-off-by: Petr Štetiar <ynezz@true.cz> [rebase, extend commit message] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/sunxi')
-rw-r--r--target/linux/sunxi/image/cortexa7.mk8
-rw-r--r--target/linux/sunxi/profiles/00-default.mk2
2 files changed, 5 insertions, 5 deletions
diff --git a/target/linux/sunxi/image/cortexa7.mk b/target/linux/sunxi/image/cortexa7.mk
index 69eb321c7f..083010ad8c 100644
--- a/target/linux/sunxi/image/cortexa7.mk
+++ b/target/linux/sunxi/image/cortexa7.mk
@@ -26,7 +26,7 @@ define Device/friendlyarm_nanopi-m1-plus
DEVICE_VENDOR := FriendlyARM
DEVICE_MODEL := NanoPi M1 Plus
DEVICE_PACKAGES:=kmod-rtc-sunxi kmod-leds-gpio kmod-ledtrig-heartbeat \
- kmod-brcmfmac brcmfmac-firmware-43430-sdio wpad-basic
+ kmod-brcmfmac brcmfmac-firmware-43430-sdio wpad-basic-wolfssl
SOC := sun8i-h3
endef
TARGET_DEVICES += friendlyarm_nanopi-m1-plus
@@ -42,7 +42,7 @@ define Device/friendlyarm_nanopi-neo-air
DEVICE_VENDOR := FriendlyARM
DEVICE_MODEL := NanoPi NEO Air
DEVICE_PACKAGES := kmod-rtc-sunxi kmod-leds-gpio kmod-ledtrig-heartbeat \
- kmod-brcmfmac brcmfmac-firmware-43430-sdio wpad-basic
+ kmod-brcmfmac brcmfmac-firmware-43430-sdio wpad-basic-wolfssl
SOC := sun8i-h3
endef
TARGET_DEVICES += friendlyarm_nanopi-neo-air
@@ -50,7 +50,7 @@ TARGET_DEVICES += friendlyarm_nanopi-neo-air
define Device/lamobo_lamobo-r1
DEVICE_VENDOR := Lamobo
DEVICE_MODEL := Lamobo R1
- DEVICE_PACKAGES:=kmod-ata-sunxi kmod-rtl8192cu swconfig wpad-basic
+ DEVICE_PACKAGES:=kmod-ata-sunxi kmod-rtl8192cu swconfig wpad-basic-wolfssl
SOC := sun7i-a20
endef
TARGET_DEVICES += lamobo_lamobo-r1
@@ -133,7 +133,7 @@ define Device/sinovoip_bananapi-m2-plus
DEVICE_VENDOR := Sinovoip
DEVICE_MODEL := Banana Pi M2+
DEVICE_PACKAGES:=kmod-rtc-sunxi kmod-leds-gpio kmod-ledtrig-heartbeat \
- kmod-brcmfmac brcmfmac-firmware-43430a0-sdio wpad-basic
+ kmod-brcmfmac brcmfmac-firmware-43430a0-sdio wpad-basic-wolfssl
SOC := sun8i-h3
endef
TARGET_DEVICES += sinovoip_bananapi-m2-plus
diff --git a/target/linux/sunxi/profiles/00-default.mk b/target/linux/sunxi/profiles/00-default.mk
index cecdd0b837..7dc791ecde 100644
--- a/target/linux/sunxi/profiles/00-default.mk
+++ b/target/linux/sunxi/profiles/00-default.mk
@@ -16,7 +16,7 @@ define Profile/Default
kmod-sun4i-emac \
rtl8188eu-firmware \
swconfig \
- wpad-basic
+ wpad-basic-wolfssl
PRIORITY := 1
endef