aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/sunxi
diff options
context:
space:
mode:
authorZoltan HERPAI <wigyori@uid0.hu>2021-01-18 09:00:42 +0100
committerZoltan HERPAI <wigyori@uid0.hu>2021-04-12 14:02:02 +0200
commit9aa66b8ce730aebff76d353392151708a897a3a0 (patch)
treeccd0a1acdf9d156b3c3430ecd0b710cea77d7e50 /target/linux/sunxi
parent172fa3bc7544ce940ce724d682d66109a3e14a11 (diff)
downloadupstream-9aa66b8ce730aebff76d353392151708a897a3a0.tar.gz
upstream-9aa66b8ce730aebff76d353392151708a897a3a0.tar.bz2
upstream-9aa66b8ce730aebff76d353392151708a897a3a0.zip
sunxi: add support for Banana Pi M2 Berry
CPU: Allwinner V40 quad-core Cortex A7 @ 1.2GHz Memory: 1GB DDR3 Storage: SDcard, native SATA Network: 10/100/1000M ethernet, Ampak AP6212 wifi + BT USB: 4x USB 2.0 Installation: Use the standard sunxi installation to an SD-card. While the board is very similar to the M2 Ultra board (the V40 is the automotive version of the R40), as both the u-boot and kernel supports them separately, and some pins are different, let's add a separate device spec. Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
Diffstat (limited to 'target/linux/sunxi')
-rw-r--r--target/linux/sunxi/image/cortexa7.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/sunxi/image/cortexa7.mk b/target/linux/sunxi/image/cortexa7.mk
index b55e93b7fb..01474a20cb 100644
--- a/target/linux/sunxi/image/cortexa7.mk
+++ b/target/linux/sunxi/image/cortexa7.mk
@@ -77,6 +77,16 @@ define Device/lemaker_bananapi
endef
TARGET_DEVICES += lemaker_bananapi
+define Device/sinovoip_bananapi-m2-berry
+ DEVICE_VENDOR := Sinovoip
+ DEVICE_MODEL := Banana Pi M2 Berry
+ DEVICE_PACKAGES:=kmod-rtc-sunxi kmod-ata-sunxi kmod-brcmfmac \
+ brcmfmac-firmware-43430-sdio wpad-basic-wolfssl
+ SUPPORTED_DEVICES:=lemaker,bananapi-m2-berry
+ SOC := sun8i-v40
+endef
+TARGET_DEVICES += sinovoip_bananapi-m2-berry
+
define Device/sinovoip_bananapi-m2-ultra
DEVICE_VENDOR := Sinovoip
DEVICE_MODEL := Banana Pi M2 Ultra