aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/sunxi
diff options
context:
space:
mode:
authorSungbo Eo <mans0n@gorani.run>2020-03-10 15:41:09 +0900
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-03-21 19:55:12 +0100
commit5b392c7119f23aef10ffc0def9a70e8335f9f3f8 (patch)
tree73e56336895a2944f0cb8dfedfd04f7b7d7d6e67 /target/linux/sunxi
parentd5812478ad4c882256e43a2ad52ddf0c0944db7b (diff)
downloadupstream-5b392c7119f23aef10ffc0def9a70e8335f9f3f8.tar.gz
upstream-5b392c7119f23aef10ffc0def9a70e8335f9f3f8.tar.bz2
upstream-5b392c7119f23aef10ffc0def9a70e8335f9f3f8.zip
treewide: gather DEVICE_VARS into one place
Place DEVICE_VARS assignments at the top of the file or above Device/Default to make them easier to find. For ramips, remove redundant values already present in parent file. Signed-off-by: Sungbo Eo <mans0n@gorani.run> [do not touch ar71xx, extend commit message] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/sunxi')
-rw-r--r--target/linux/sunxi/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/sunxi/image/Makefile b/target/linux/sunxi/image/Makefile
index cb8febca41..1b98849a50 100644
--- a/target/linux/sunxi/image/Makefile
+++ b/target/linux/sunxi/image/Makefile
@@ -11,6 +11,7 @@ include $(INCLUDE_DIR)/image.mk
FAT32_BLOCK_SIZE=1024
FAT32_BLOCKS=$(shell echo $$(($(CONFIG_SUNXI_SD_BOOT_PARTSIZE)*1024*1024/$(FAT32_BLOCK_SIZE))))
+DEVICE_VARS := SUNXI_DTS SUNXI_DTS_DIR
KERNEL_LOADADDR:=0x40008000
define Build/sunxi-sdcard
@@ -32,7 +33,6 @@ endef
# why \x00\x00\x00\x00 for zImage-initramfs
define Device/Default
PROFILES := Default
- DEVICE_VARS := SUNXI_DTS SUNXI_DTS_DIR
KERNEL_NAME := zImage
KERNEL := kernel-bin | uImage none
IMAGES := sdcard.img.gz