aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/sunxi/patches-3.18/110-input-add-sun4i-lradc.patch
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2015-05-21 19:32:46 +0000
committerJonas Gorski <jogo@openwrt.org>2015-05-21 19:32:46 +0000
commit9157f620436a8383b13c30c0a26ad06b976b1a0b (patch)
tree768c585c31df15ffc89cd03480ce4558ea291ca0 /target/linux/sunxi/patches-3.18/110-input-add-sun4i-lradc.patch
parent19deb0cf132ecd6cd1b4aa79fcc4462c698a38dd (diff)
downloadupstream-9157f620436a8383b13c30c0a26ad06b976b1a0b.tar.gz
upstream-9157f620436a8383b13c30c0a26ad06b976b1a0b.tar.bz2
upstream-9157f620436a8383b13c30c0a26ad06b976b1a0b.zip
kernel: update 3.18 to 3.18.14
Changelogs: * https://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.18.12 * https://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.18.13 * https://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.18.14 Build tested on brcm63xx and ipq806x, runtested on brcm63xx. Signed-off-by: Jonas Gorski <jogo@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45711 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/sunxi/patches-3.18/110-input-add-sun4i-lradc.patch')
-rw-r--r--target/linux/sunxi/patches-3.18/110-input-add-sun4i-lradc.patch16
1 files changed, 2 insertions, 14 deletions
diff --git a/target/linux/sunxi/patches-3.18/110-input-add-sun4i-lradc.patch b/target/linux/sunxi/patches-3.18/110-input-add-sun4i-lradc.patch
index 0772f1572d..12b4628f04 100644
--- a/target/linux/sunxi/patches-3.18/110-input-add-sun4i-lradc.patch
+++ b/target/linux/sunxi/patches-3.18/110-input-add-sun4i-lradc.patch
@@ -27,9 +27,6 @@ Changes in v2:
create mode 100644 Documentation/devicetree/bindings/input/sun4i-lradc-keys.txt
create mode 100644 drivers/input/keyboard/sun4i-lradc-keys.c
-diff --git a/Documentation/devicetree/bindings/input/sun4i-lradc-keys.txt b/Documentation/devicetree/bindings/input/sun4i-lradc-keys.txt
-new file mode 100644
-index 0000000..b9c32f6
--- /dev/null
+++ b/Documentation/devicetree/bindings/input/sun4i-lradc-keys.txt
@@ -0,0 +1,62 @@
@@ -95,11 +92,9 @@ index 0000000..b9c32f6
+ voltage = <987387>;
+ };
+ };
-diff --git a/MAINTAINERS b/MAINTAINERS
-index a20df9b..73d1aef 100644
--- a/MAINTAINERS
+++ b/MAINTAINERS
-@@ -8932,6 +8932,13 @@ F: arch/m68k/sun3*/
+@@ -9002,6 +9002,13 @@ F: arch/m68k/sun3*/
F: arch/m68k/include/asm/sun3*
F: drivers/net/ethernet/i825xx/sun3*
@@ -113,8 +108,6 @@ index a20df9b..73d1aef 100644
SUNDANCE NETWORK DRIVER
M: Denis Kirjanov <kda@linux-powerpc.org>
L: netdev@vger.kernel.org
-diff --git a/drivers/input/keyboard/Kconfig b/drivers/input/keyboard/Kconfig
-index a3958c6..2d11b44 100644
--- a/drivers/input/keyboard/Kconfig
+++ b/drivers/input/keyboard/Kconfig
@@ -567,6 +567,16 @@ config KEYBOARD_STMPE
@@ -134,11 +127,9 @@ index a3958c6..2d11b44 100644
config KEYBOARD_DAVINCI
tristate "TI DaVinci Key Scan"
depends on ARCH_DAVINCI_DM365
-diff --git a/drivers/input/keyboard/Makefile b/drivers/input/keyboard/Makefile
-index 0a33456..a35269a 100644
--- a/drivers/input/keyboard/Makefile
+++ b/drivers/input/keyboard/Makefile
-@@ -53,6 +53,7 @@ obj-$(CONFIG_KEYBOARD_SPEAR) += spear-keyboard.o
+@@ -53,6 +53,7 @@ obj-$(CONFIG_KEYBOARD_SPEAR) += spear-k
obj-$(CONFIG_KEYBOARD_STMPE) += stmpe-keypad.o
obj-$(CONFIG_KEYBOARD_STOWAWAY) += stowaway.o
obj-$(CONFIG_KEYBOARD_ST_KEYSCAN) += st-keyscan.o
@@ -146,9 +137,6 @@ index 0a33456..a35269a 100644
obj-$(CONFIG_KEYBOARD_SUNKBD) += sunkbd.o
obj-$(CONFIG_KEYBOARD_TC3589X) += tc3589x-keypad.o
obj-$(CONFIG_KEYBOARD_TEGRA) += tegra-kbc.o
-diff --git a/drivers/input/keyboard/sun4i-lradc-keys.c b/drivers/input/keyboard/sun4i-lradc-keys.c
-new file mode 100644
-index 0000000..f11f002
--- /dev/null
+++ b/drivers/input/keyboard/sun4i-lradc-keys.c
@@ -0,0 +1,258 @@