aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/sunxi/image/cortex-a8.mk
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-06-07 13:11:15 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-06-11 01:44:13 +0200
commitbb39fea11aae2888e6a0129055de21995da92073 (patch)
tree5dcca668bad0414fc458db065424b4ecc456e20a /target/linux/sunxi/image/cortex-a8.mk
parent108df3eabbb4dd93ff3c616c9455d69daaa98b49 (diff)
downloadupstream-bb39fea11aae2888e6a0129055de21995da92073.tar.gz
upstream-bb39fea11aae2888e6a0129055de21995da92073.tar.bz2
upstream-bb39fea11aae2888e6a0129055de21995da92073.zip
treewide: simplify inclusion of subtarget image files
Many target use a repetitive if-include scheme for their subtarget image files, though their names are consistent with the subtarget names. This patch removes these redundant conditions and just uses the variable for the include where the target setup allows it. For sunxi, this includes a trivial rename of the subtarget image Makefiles. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/sunxi/image/cortex-a8.mk')
-rw-r--r--target/linux/sunxi/image/cortex-a8.mk58
1 files changed, 0 insertions, 58 deletions
diff --git a/target/linux/sunxi/image/cortex-a8.mk b/target/linux/sunxi/image/cortex-a8.mk
deleted file mode 100644
index 643b3d4b1e..0000000000
--- a/target/linux/sunxi/image/cortex-a8.mk
+++ /dev/null
@@ -1,58 +0,0 @@
-#
-# Copyright (C) 2013-2016 OpenWrt.org
-# Copyright (C) 2016 Yousong Zhou
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Device/cubietech_a10-cubieboard
- DEVICE_VENDOR := Cubietech
- DEVICE_MODEL := Cubieboard
- DEVICE_PACKAGES:=kmod-ata-sunxi kmod-sun4i-emac kmod-rtc-sunxi
- SOC := sun4i
-endef
-TARGET_DEVICES += cubietech_a10-cubieboard
-
-define Device/linksprite_a10-pcduino
- DEVICE_VENDOR := LinkSprite
- DEVICE_MODEL := pcDuino
- DEVICE_PACKAGES:=kmod-sun4i-emac kmod-rtc-sunxi kmod-rtl8192cu
- SOC := sun4i
-endef
-TARGET_DEVICES += linksprite_a10-pcduino
-
-define Device/marsboard_a10-marsboard
- DEVICE_VENDOR := HAOYU Electronics
- DEVICE_MODEL := MarsBoard A10
- DEVICE_PACKAGES:=mod-ata-core kmod-ata-sunxi kmod-sun4i-emac kmod-rtc-sunxi \
- sound-soc-sunxi
- SOC := sun4i
-endef
-TARGET_DEVICES += marsboard_a10-marsboard
-
-define Device/olimex_a10-olinuxino-lime
- DEVICE_VENDOR := Olimex
- DEVICE_MODEL := A10-OLinuXino-LIME
- DEVICE_PACKAGES:=kmod-ata-sunxi kmod-sun4i-emac kmod-rtc-sunxi
- SOC := sun4i
-endef
-TARGET_DEVICES += olimex_a10-olinuxino-lime
-
-define Device/olimex_a13-olimex-som
- DEVICE_VENDOR := Olimex
- DEVICE_MODEL := A13-SOM
- DEVICE_PACKAGES:=kmod-rtl8192cu
- SUPPORTED_DEVICES:=olimex,a13-olinuxino
- SOC := sun5i-a13
- SUNXI_DTS := sun5i-a13-olinuxino
-endef
-TARGET_DEVICES += olimex_a13-olimex-som
-
-define Device/olimex_a13-olinuxino
- DEVICE_VENDOR := Olimex
- DEVICE_MODEL := A13-OLinuXino
- DEVICE_PACKAGES:=kmod-rtl8192cu
- SOC := sun5i
-endef
-TARGET_DEVICES += olimex_a13-olinuxino