aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/sunxi/image/cortex-a8.mk
diff options
context:
space:
mode:
authorKayo Phoenix <kayo@illumium.org>2017-10-22 22:21:25 +0200
committerJohn Crispin <john@phrozen.org>2017-11-06 16:39:41 +0100
commit6a3565985fde9f2bdaeea24435e851364aecef4e (patch)
treebdd99e39f40f6c20a1cb027dc5d2ea9fa0ab4872 /target/linux/sunxi/image/cortex-a8.mk
parent63d7c458867b62bda7662a897c05ac79aab21f5a (diff)
downloadupstream-6a3565985fde9f2bdaeea24435e851364aecef4e.tar.gz
upstream-6a3565985fde9f2bdaeea24435e851364aecef4e.tar.bz2
upstream-6a3565985fde9f2bdaeea24435e851364aecef4e.zip
sunxi: Added profile for HAOYU Electronics Marsboard A10
The MarsBoard was a short-lived credit-card sized, extendable board with an Allwinner A10 SoC. http://linux-sunxi.org/MarsBoard_A10 Signed-off-by: Kayo Phoenix <kayo@illumium.org> [Forward-ported to new target layout:] Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
Diffstat (limited to 'target/linux/sunxi/image/cortex-a8.mk')
-rw-r--r--target/linux/sunxi/image/cortex-a8.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/sunxi/image/cortex-a8.mk b/target/linux/sunxi/image/cortex-a8.mk
index 97e033dbb3..564a66f938 100644
--- a/target/linux/sunxi/image/cortex-a8.mk
+++ b/target/linux/sunxi/image/cortex-a8.mk
@@ -56,4 +56,14 @@ endef
TARGET_DEVICES += sun4i-a10-pcduino
+
+define Device/sun4i-a10-marsboard
+ DEVICE_TITLE:=HAOYU Electronics Marsboard A10
+ DEVICE_PACKAGES:=mod-ata-core kmod-ata-sunxi kmod-sun4i-emac kmod-rtc-sunxi sound-soc-sunxi
+ SUPPORTED_DEVICES:=marsboard,a10-marsboard
+ SUNXI_DTS:=sun4i-a10-marsboard
+endef
+
+TARGET_DEVICES += sun4i-a10-marsboard
+
endif