aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/sunxi/image/cortex-a7.mk
diff options
context:
space:
mode:
authorLuis Araneda <luaraneda@gmail.com>2017-10-19 00:18:41 -0300
committerJohn Crispin <john@phrozen.org>2017-11-17 08:20:30 +0100
commitb31c1237c749b927d296f18c16894f162abccd30 (patch)
treebb9c6dfe3572a1e1944136b4bfaa2568c5b9b603 /target/linux/sunxi/image/cortex-a7.mk
parent1c139d664b2673350c14d4b45e701c894bd39880 (diff)
downloadupstream-b31c1237c749b927d296f18c16894f162abccd30.tar.gz
upstream-b31c1237c749b927d296f18c16894f162abccd30.tar.bz2
upstream-b31c1237c749b927d296f18c16894f162abccd30.zip
sunxi: add support for NanoPi M1 Plus board
Backported devicetree from Kernel 4.13 with some additions to enable Ethernet and WiFi module The following features are working: - Ethernet - WiFi - eMMC and microSD slot - USB ports The following features are not working: * Bluetooth NanoPi M1 Plus key features - SoC: Allwinner H3, Quad-core Cortex-A7@1.2GHz - RAM: 1GB DDR3 - eMMC: 8GB - microSD slot - Ethernet 10/100/1000M - Wifi: AP6212 Signed-off-by: Luis Araneda <luaraneda@gmail.com>
Diffstat (limited to 'target/linux/sunxi/image/cortex-a7.mk')
-rw-r--r--target/linux/sunxi/image/cortex-a7.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/target/linux/sunxi/image/cortex-a7.mk b/target/linux/sunxi/image/cortex-a7.mk
index d219a1d097..229b055e68 100644
--- a/target/linux/sunxi/image/cortex-a7.mk
+++ b/target/linux/sunxi/image/cortex-a7.mk
@@ -118,6 +118,18 @@ endef
TARGET_DEVICES += sun8i-h2-plus-orangepi-r1
+define Device/sun8i-h3-nanopi-m1-plus
+ DEVICE_TITLE:=FriendlyArm NanoPi M1 Plus
+ DEVICE_PACKAGES:=kmod-rtc-sunxi \
+ kmod-leds-gpio kmod-ledtrig-heartbeat \
+ kmod-brcmfmac brcmfmac-firmware-43430-sdio wpad-mini
+ SUPPORTED_DEVICES:=friendlyarm,nanopi-m1-plus
+ SUNXI_DTS:=sun8i-h3-nanopi-m1-plus
+endef
+
+TARGET_DEVICES += sun8i-h3-nanopi-m1-plus
+
+
define Device/sun8i-h3-nanopi-neo
DEVICE_TITLE:=FriendlyARM NanoPi NEO
SUPPORTED_DEVICES:=friendlyarm,nanopi-neo