aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/sunxi/image/cortex-a7.mk
diff options
context:
space:
mode:
authorVitalij Alshevsky <v_alshevsky@tut.by>2018-02-25 21:12:49 +0300
committerHauke Mehrtens <hauke@hauke-m.de>2018-02-26 11:24:04 +0100
commit70130268a85ea2373c6787414a20caa31ab05df7 (patch)
tree16e39d158fbd74353dee37abc8f70e0c8974e697 /target/linux/sunxi/image/cortex-a7.mk
parent8584fee3102ac93088d7ee328219cd0691f15837 (diff)
downloadupstream-70130268a85ea2373c6787414a20caa31ab05df7.tar.gz
upstream-70130268a85ea2373c6787414a20caa31ab05df7.tar.bz2
upstream-70130268a85ea2373c6787414a20caa31ab05df7.zip
sunxi: Add support for Xunlong Orange Pi PC
CPU: H3 Quad-core Cortex-A7 H.265/HEVC 4K @ 1.3 Ghz GPU: Mali400MP2 GPU @ 600MHz (supports OpenGL ES 2.0) Memory: 1GB DDR3 (shared with GPU) Onboard: Storage TF card (Max. 64GB) / MMC card slot Onboard: Network 10/100M Ethernet RJ45 Onboard header pinout: SPI, I2C, 1-WIRE USB 2.0: Three USB 2.0 HOST, One USB 2.0 OTG Buttons: Power Button(SW4) Debug TTL UART: ..DC-IN.. >[GND][RX][TX] ..HDMI.. Signed-off-by: Vitalij Alshevsky <v_alshevsky@tut.by>
Diffstat (limited to 'target/linux/sunxi/image/cortex-a7.mk')
-rw-r--r--target/linux/sunxi/image/cortex-a7.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/sunxi/image/cortex-a7.mk b/target/linux/sunxi/image/cortex-a7.mk
index 229b055e68..986b6395c4 100644
--- a/target/linux/sunxi/image/cortex-a7.mk
+++ b/target/linux/sunxi/image/cortex-a7.mk
@@ -139,6 +139,16 @@ endef
TARGET_DEVICES += sun8i-h3-nanopi-neo
+define Device/sun8i-h3-orangepi-pc
+ DEVICE_TITLE:=Xunlong Orange Pi PC
+ DEVICE_PACKAGES:=kmod-rtc-sunxi kmod-gpio-button-hotplug
+ SUPPORTED_DEVICES:=xunlong,orangepi-pc
+ SUNXI_DTS:=sun8i-h3-orangepi-pc
+endef
+
+TARGET_DEVICES += sun8i-h3-orangepi-pc
+
+
define Device/sun8i-h3-orangepi-plus
DEVICE_TITLE:=Xunlong Orange Pi Plus
DEVICE_PACKAGES:=kmod-rtc-sunxi