aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/sunxi/image/cortex-a7.mk
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2017-09-20 19:32:01 +0200
committerDaniel Golle <daniel@makrotopia.org>2017-10-08 17:16:39 +0200
commit34b153d7adc0aa9c34db75a5d324bf03c4159b4b (patch)
tree177fd52bfb287fabd00fe1aa5d38c6bcb7b86cd7 /target/linux/sunxi/image/cortex-a7.mk
parent333f90347e76e6c0c121c1c7df917780eef8b59e (diff)
downloadupstream-34b153d7adc0aa9c34db75a5d324bf03c4159b4b.tar.gz
upstream-34b153d7adc0aa9c34db75a5d324bf03c4159b4b.tar.bz2
upstream-34b153d7adc0aa9c34db75a5d324bf03c4159b4b.zip
sunxi: build image for the NanoPi NEO
The NanoPi NEO is a small Allwinner H3 based board available with different DRAM configurations. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'target/linux/sunxi/image/cortex-a7.mk')
-rw-r--r--target/linux/sunxi/image/cortex-a7.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/target/linux/sunxi/image/cortex-a7.mk b/target/linux/sunxi/image/cortex-a7.mk
index 29c30ef494..d0b7aa04b6 100644
--- a/target/linux/sunxi/image/cortex-a7.mk
+++ b/target/linux/sunxi/image/cortex-a7.mk
@@ -118,6 +118,15 @@ endef
TARGET_DEVICES += sun8i-h2-plus-orangepi-r1
+define Device/sun8i-h3-nanopi-neo
+ DEVICE_TITLE:=FriendlyARM NanoPi NEO
+ SUPPORTED_DEVICES:=friendlyarm,nanopi-neo
+ SUNXI_DTS:=sun8i-h3-nanopi-neo
+endef
+
+TARGET_DEVICES += sun8i-h3-nanopi-neo
+
+
define Device/sun8i-h3-orangepi-plus
DEVICE_TITLE:=Xunlong Orange Pi Plus
DEVICE_PACKAGES:=kmod-rtc-sunxi