aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/sunxi/image/cortex-a7.mk
diff options
context:
space:
mode:
authorAleksander Jan Bajkowski <A.Bajkowski@stud.elka.pw.edu.pl>2019-02-20 14:17:45 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2019-02-26 23:20:04 +0100
commit00d89b4a89936cfb86aa57fbb99f33efda80981f (patch)
treec30385d31f88dca417caac79f41303c91b4dd8ef /target/linux/sunxi/image/cortex-a7.mk
parent4ecf2ee4a0d375d198f515c3e038de62323e0b85 (diff)
downloadupstream-00d89b4a89936cfb86aa57fbb99f33efda80981f.tar.gz
upstream-00d89b4a89936cfb86aa57fbb99f33efda80981f.tar.bz2
upstream-00d89b4a89936cfb86aa57fbb99f33efda80981f.zip
sunxi: add support for Orange Pi One
CPU: H3 Quad-core Cortex-A7 H.265/HEVC 4K @ 1.2 Ghz GPU: Mali400MP2 GPU @ 600MHz (supports OpenGL ES 2.0) Memory: 512MB DDR3 (shared with GPU) Onboard: Storage TF card (Max. 64GB) / MMC card slot Onboard header: SPI, I2C, GPIO, UART USB 2.0: One USB 2.0 HOST, One USB 2.0 OTG Signed-off-by: Aleksander Jan Bajkowski <A.Bajkowski@stud.elka.pw.edu.pl>
Diffstat (limited to 'target/linux/sunxi/image/cortex-a7.mk')
-rw-r--r--target/linux/sunxi/image/cortex-a7.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/sunxi/image/cortex-a7.mk b/target/linux/sunxi/image/cortex-a7.mk
index 58c3b6fc40..a9045c7d5a 100644
--- a/target/linux/sunxi/image/cortex-a7.mk
+++ b/target/linux/sunxi/image/cortex-a7.mk
@@ -159,6 +159,16 @@ endef
TARGET_DEVICES += sun8i-h3-nanopi-neo
+define Device/sun8i-h3-orangepi-one
+ DEVICE_TITLE:=Xunlong Orange Pi One
+ DEVICE_PACKAGES:=kmod-rtc-sunxi
+ SUPPORTED_DEVICES:=xunlong,orangepi-one
+ SUNXI_DTS:=sun8i-h3-orangepi-one
+endef
+
+TARGET_DEVICES += sun8i-h3-orangepi-one
+
+
define Device/sun8i-h3-orangepi-pc
DEVICE_TITLE:=Xunlong Orange Pi PC
DEVICE_PACKAGES:=kmod-rtc-sunxi kmod-gpio-button-hotplug