aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/sunxi/image/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2017-01-27 16:18:05 +0100
committerJo-Philipp Wich <jo@mein.io>2017-01-27 16:53:31 +0100
commitcf3d1b61bfc3f2dd6affe6e59019801d00f7f85f (patch)
treed290d77099ea37a2d1128e7d24bc3b989a874f45 /target/linux/sunxi/image/Makefile
parentc6502ce3bb87b6a6a85209d3e67736bd2db21bc7 (diff)
downloadupstream-cf3d1b61bfc3f2dd6affe6e59019801d00f7f85f.tar.gz
upstream-cf3d1b61bfc3f2dd6affe6e59019801d00f7f85f.tar.bz2
upstream-cf3d1b61bfc3f2dd6affe6e59019801d00f7f85f.zip
sunxi: put u-boot images into image staging directory
Do not put the u-boot images into the kernel build directory as this directory might get removed after kernel updates while the u-boot packages InstallDev recipe is not getting re-executed because it is still considered current, leading to image build failures later on due to missing images. To ensure that built bootloader images persist over kernel version updates in the buildroot, put them into the new STAGING_DIR_IMAGE directory. Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'target/linux/sunxi/image/Makefile')
-rw-r--r--target/linux/sunxi/image/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/sunxi/image/Makefile b/target/linux/sunxi/image/Makefile
index bfb8e4e429..c3f368f2e4 100644
--- a/target/linux/sunxi/image/Makefile
+++ b/target/linux/sunxi/image/Makefile
@@ -18,7 +18,7 @@ define Build/sunxi-sdcard
rm -f $@.boot
mkfs.fat $@.boot -C $(FAT32_BLOCKS)
- mcopy -i $@.boot $(KDIR)/$(DEVICE_NAME)-boot.scr ::boot.scr
+ mcopy -i $@.boot $(STAGING_DIR_IMAGE)/$(DEVICE_NAME)-boot.scr ::boot.scr
mcopy -i $@.boot $(DTS_DIR)/$(SUNXI_DTS).dtb ::dtb
mcopy -i $@.boot $(IMAGE_KERNEL) ::uImage
./gen_sunxi_sdcard_img.sh $@ \
@@ -26,7 +26,7 @@ define Build/sunxi-sdcard
$(IMAGE_ROOTFS) \
$(CONFIG_SUNXI_SD_BOOT_PARTSIZE) \
$(CONFIG_TARGET_ROOTFS_PARTSIZE) \
- $(KDIR)/$(DEVICE_NAME)-u-boot-with-spl.bin
+ $(STAGING_DIR_IMAGE)/$(DEVICE_NAME)-u-boot-with-spl.bin
rm -f $@.boot
endef