aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/sunxi/image/Makefile
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-12-06 00:11:56 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-12-13 12:19:44 +0100
commita4cdb537b17ede9785ddbaef5ed9d69f3ab89052 (patch)
tree370cc5b2eda165713da31bffa2a2e2b040e463ff /target/linux/sunxi/image/Makefile
parentc642a97aa6b51352a718449cd715b92f94af4a5d (diff)
downloadupstream-a4cdb537b17ede9785ddbaef5ed9d69f3ab89052.tar.gz
upstream-a4cdb537b17ede9785ddbaef5ed9d69f3ab89052.tar.bz2
upstream-a4cdb537b17ede9785ddbaef5ed9d69f3ab89052.zip
sunxi: use vendor_device scheme for device definitions
This changes device definition to resemble the vendor_device scheme already present for the majority of device compatible strings. By doing this, we achieve several advantages at once: - Image names and node names are more consistent with other targets. - SUPPORTED_DEVICES can be set automatically for all but two cases. - Image names and node names are in line with DEVICE_TITLEs. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/sunxi/image/Makefile')
-rw-r--r--target/linux/sunxi/image/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/target/linux/sunxi/image/Makefile b/target/linux/sunxi/image/Makefile
index 8f95c61906..04e0abee49 100644
--- a/target/linux/sunxi/image/Makefile
+++ b/target/linux/sunxi/image/Makefile
@@ -37,6 +37,7 @@ define Device/Default
KERNEL := kernel-bin | uImage none
IMAGES := sdcard.img.gz
IMAGE/sdcard.img.gz := sunxi-sdcard | append-metadata | gzip
+ SUPPORTED_DEVICES := $(subst _,$(comma),$(1))
endef
include cortex-a7.mk