aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/sunxi/Makefile
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2017-05-04 07:00:06 +0200
committerMatthias Schiffer <mschiffer@universe-factory.net>2017-05-04 07:07:18 +0200
commitbe40d0a144937a788fa8902e3335a25586acaa95 (patch)
tree8102c51648efa303a8779dffc0423af4e6c1785d /target/linux/sunxi/Makefile
parent414b65db8583b02cffa1addde57ce1b37f163aa5 (diff)
downloadupstream-be40d0a144937a788fa8902e3335a25586acaa95.tar.gz
upstream-be40d0a144937a788fa8902e3335a25586acaa95.tar.bz2
upstream-be40d0a144937a788fa8902e3335a25586acaa95.zip
sunxi: clean up modules definitions
Module definitions for kmod-wdt-sunxi and kmod-eeprom-sunxi are removed (wdt-sunxi was builtin anyways; nvmem-sunxi, which is the new name of eeprom-sunxi is changed to builtin). As kmod-eeprom-sunxi was specified in DEFAULT_PACKAGES, but not available on kernel 4.4, it was breaking the image builder. Support for kmod-sunxi-ir is added for kernel 4.4 (it is unclear why it was disable before, it builds fine with with kernel 4.4). Condtionals only relevant for pre-4.4 kernels are removed from modules.mk, as sunxi does't support older kernels anymore. Fixes FS#755. Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
Diffstat (limited to 'target/linux/sunxi/Makefile')
-rw-r--r--target/linux/sunxi/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/sunxi/Makefile b/target/linux/sunxi/Makefile
index b0bc1bab39..3c2f14b841 100644
--- a/target/linux/sunxi/Makefile
+++ b/target/linux/sunxi/Makefile
@@ -27,7 +27,7 @@ KERNELNAME:=zImage dtbs
include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES += uboot-envtools kmod-eeprom-sunxi kmod-wdt-sunxi
+DEFAULT_PACKAGES += uboot-envtools
DEFAULT_PACKAGES += mkf2fs e2fsprogs
$(eval $(call BuildTarget))