aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/sibyte-2.6/image/Makefile
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2007-05-24 21:02:53 +0000
committerImre Kaloz <kaloz@openwrt.org>2007-05-24 21:02:53 +0000
commit41e092a905d0a75eaddeaf61521a4fd5b951930b (patch)
tree01182c3ca12b6e614ce6030c637003223e6beb1d /target/linux/sibyte-2.6/image/Makefile
parent53496b7cc9b2d8b12b2758f734238d00643ff972 (diff)
downloadupstream-41e092a905d0a75eaddeaf61521a4fd5b951930b.tar.gz
upstream-41e092a905d0a75eaddeaf61521a4fd5b951930b.tar.bz2
upstream-41e092a905d0a75eaddeaf61521a4fd5b951930b.zip
fix .21 for sibyte.. because we can..
SVN-Revision: 7332
Diffstat (limited to 'target/linux/sibyte-2.6/image/Makefile')
-rw-r--r--target/linux/sibyte-2.6/image/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/target/linux/sibyte-2.6/image/Makefile b/target/linux/sibyte-2.6/image/Makefile
new file mode 100644
index 0000000000..fbff86deda
--- /dev/null
+++ b/target/linux/sibyte-2.6/image/Makefile
@@ -0,0 +1,37 @@
+#
+# Copyright (C) 2007 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
+#define Image/Prepare
+# cp $(LINUX_DIR)/arch/arm/boot/zImage $(KDIR)/zImage
+#endef
+
+define Image/BuildKernel
+ cp $(KDIR)/vmlinux $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinux
+endef
+
+define Image/Build
+ $(call Image/Build/$(1),$(1))
+endef
+
+define Image/Build/jffs2-64k
+ dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img bs=65536 conv=sync
+endef
+
+define Image/Build/jffs2-128k
+ dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img bs=131072 conv=sync
+ $(call Image/Build/slug,$(1))
+endef
+
+define Image/Build/squashfs
+ $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
+ dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img bs=131072 conv=sync
+ $(call Image/Build/slug,$(1))
+endef
+
+$(eval $(call BuildImage))