aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/samsung
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-12-28 16:04:48 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-01-03 00:04:05 +0100
commit6e70e4a071b233da83486414e65d15756ede63d2 (patch)
treec288270b8291f27e55096a754f8bf8a69a868198 /target/linux/samsung
parente37e2f0cf1be1d31d4e056de1a9177221b6a78f0 (diff)
downloadupstream-6e70e4a071b233da83486414e65d15756ede63d2.tar.gz
upstream-6e70e4a071b233da83486414e65d15756ede63d2.tar.bz2
upstream-6e70e4a071b233da83486414e65d15756ede63d2.zip
samsung: use soc_vendor_model scheme for DTS file name
This patch changes the samsung target to calculate the DTS file name from vendor and device name and the SOC (i.e. subtarget) following the common scheme: soc_vendor_model.dts This also updates the device definition name to make compatible, image name, menuconfig name and DTS name consistent. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/samsung')
-rw-r--r--target/linux/samsung/dts/s5pv210_embedsky_tq210.dts (renamed from target/linux/samsung/dts/TQ210.dts)0
-rw-r--r--target/linux/samsung/image/Makefile11
2 files changed, 6 insertions, 5 deletions
diff --git a/target/linux/samsung/dts/TQ210.dts b/target/linux/samsung/dts/s5pv210_embedsky_tq210.dts
index d32e3400f9..d32e3400f9 100644
--- a/target/linux/samsung/dts/TQ210.dts
+++ b/target/linux/samsung/dts/s5pv210_embedsky_tq210.dts
diff --git a/target/linux/samsung/image/Makefile b/target/linux/samsung/image/Makefile
index 697d317c9f..53509ef137 100644
--- a/target/linux/samsung/image/Makefile
+++ b/target/linux/samsung/image/Makefile
@@ -13,14 +13,15 @@ define Device/Default
PROFILES = Default
KERNEL_NAME := zImage
KERNEL := kernel-bin | append-dtb | uImage none
+ DEVICE_DTS_DIR := ../dts
+ DEVICE_DTS = $$(SOC)_$(1)
endef
-define Device/tq210
- DEVICE_VENDOR := Samsung
+define Device/embedsky_tq210
+ DEVICE_VENDOR := EmbedSky
DEVICE_MODEL := TQ210
- DEVICE_DTS_DIR := ../dts
- DEVICE_DTS := TQ210
+ SOC := s5pv210
endef
-TARGET_DEVICES += tq210
+TARGET_DEVICES += embedsky_tq210
$(eval $(call BuildImage))