aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/rtl838x/image/Makefile
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2020-11-04 10:39:42 +0100
committerPetr Štetiar <ynezz@true.cz>2020-11-09 09:14:02 +0100
commitaeb26f8434bdc9d4263328a0b7493fae5d74b334 (patch)
treeaebf05ed5842512f4f5b22eefa4f996620277883 /target/linux/rtl838x/image/Makefile
parentb1b8abaf588e7ec269e924828bcd40a0a9738b0d (diff)
downloadupstream-aeb26f8434bdc9d4263328a0b7493fae5d74b334.tar.gz
upstream-aeb26f8434bdc9d4263328a0b7493fae5d74b334.tar.bz2
upstream-aeb26f8434bdc9d4263328a0b7493fae5d74b334.zip
rtl838x: d-link_dgs-1210: refactor common family bits
So the common bits can be easily shared with other boards in the family and while at it add missing SPDX license identifiers into the DTS files and fixed alphabetic sorting of the devices in the images. Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'target/linux/rtl838x/image/Makefile')
-rw-r--r--target/linux/rtl838x/image/Makefile16
1 files changed, 9 insertions, 7 deletions
diff --git a/target/linux/rtl838x/image/Makefile b/target/linux/rtl838x/image/Makefile
index f490fa7ffe..cd384c5345 100644
--- a/target/linux/rtl838x/image/Makefile
+++ b/target/linux/rtl838x/image/Makefile
@@ -41,22 +41,24 @@ define Device/allnet_all-sg8208m
endef
TARGET_DEVICES += allnet_all-sg8208m
-define Device/d-link_dgs-1210-16
+define Device/d-link_dgs-1210
SOC := rtl8382
IMAGE_SIZE := 13824k
DEVICE_VENDOR := D-Link
- DEVICE_MODEL := DGS-1210-16
DEVICE_PACKAGES := ip-full ip-bridge ethtool tc
endef
-TARGET_DEVICES += d-link_dgs-1210-16
define Device/d-link_dgs-1210-10p
- SOC := rtl8382
- IMAGE_SIZE := 13824k
- DEVICE_VENDOR := D-Link
+ $(Device/d-link_dgs-1210)
DEVICE_MODEL := DGS-1210-10P
- DEVICE_PACKAGES := ip-full ip-bridge ethtool tc lua-rs232
+ DEVICE_PACKAGES += lua-rs232
endef
TARGET_DEVICES += d-link_dgs-1210-10p
+define Device/d-link_dgs-1210-16
+ $(Device/d-link_dgs-1210)
+ DEVICE_MODEL := DGS-1210-16
+endef
+TARGET_DEVICES += d-link_dgs-1210-16
+
$(eval $(call BuildImage))